[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [birt-dev] [REQUIRED] Update org.eclipse.jetty.* plugins to 9.4.7

This is the bugzilla related with eclipse platform change:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=522072
 
So this is required for BIRT component as well in 4.7.2. A feature patch could not be created because org.eclipse.birt feature doesn't take a specific jetty plugins version. The change should be done in Birt repository or in source code if it is required.
 
Regards
 
----- Original message -----
From: Gloria Avila Patron/Mexico/HCL/IDE
To: birt-dev@xxxxxxxxxxx
Cc: kalena.blue@xxxxxxx, steve.campbell@xxxxxxx, David Christensen Arreola/Mexico/HCL/IDE@IBMMX, cesar.cervantes@xxxxxxx
Subject: [REQUIRED] Update org.eclipse.jetty.* plugins to 9.4.7
Date: Tue, Feb 20, 2018 12:39 PM
 
Hi
 
In IES 4.7.2 all components upgraded from 9.4.5 to 9.4.7 for the next plugins:
 
 
These org.eclipse.jetty.* plugins are required by org.eclipse.birt.report.viewer BIRT plugin (probably there are more plugins with this dependency). Having two different versions for the same plugins is causing big issues at time to consume all IES components together, so it is required that the birt plugins/feature using these jetty plugins upgrade to 9.4.7 version so all components are in sync and avoid issues. I already opened a Bugzilla ticket for track this:
 
We appreciate the upgrade fix as soon as possible as this is blocking out test phase.
 
Regards