Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[hudson-dev] Fwd: Aligment of plugin names

Again this went only to the sender

---------- Forwarded message ----------
From: Henrik Lynggaard Hansen <henrik@xxxxxxx>
Date: 2012/1/28
Subject: Re: [hudson-dev] Aligment of plugin names
To: Winston Prakash <winston.prakash@xxxxxxxxx>

2012/1/27 Winston Prakash <winston.prakash@xxxxxxxxx>:
> I like the <name> "Hudson BIRT Charts Plugin", because this will be used as
> project name in the IDE. This makes it easy to find the project in the list
> of so many other projects. Also the name "Hudson :: Maven 3 :: Plugin",
> tells me "Maven3" is a "Plugin" available as module inside the main project
> "Hudson".

I can see your point and it is all about the context. Usign Hudson
makes it easier to find in a big list, but if I only have Hudson
related code open in my IDE that part fo the name becomes redundant.
I have no problems with a naming standard that includes "Hudson" and
"plugin", but then we should align the other plugins like "JCaptcha
Plugin" and "JFreeChart  Plugin" to follow that standard.

"Hudson :: Maven 3 :: Plugin" is a bit harder. On one hand the "::"
notation works as a delimiter saying this group of projects belong to
the Maven3 functionality, and in that we have a plugin which in itself
works nicely, but in a list of just the plugins it is sticking out a
bit. Personally I am partial to leaving it as is, because I think the
functionality grouping is more important.

> To solve this problem we could introduce a POM property called
> "displayName". Ex
> <properties>
>     <displayName>Birt Chart</displayName>
> </properties>
> The update center generator would use this property, if available" to fill
> the JSON attribute "title" or revert to <name> tag.

I agree except that I don't think the property should be called just
"displayName". I think we should follow the same strategy as netbeans
which uses names like "netbeans.hint.*" (or is it "hint.netbeans.*").
So something like "hudson.hint.displayName" would be better.

Best regards

Back to the top