|Re: [hudson-dev] Aligment of plugin names|
The plugin is identified with a JSON attribute "name" and display
name comes from the JSON attribute "title".|
When the update center generator generates the JSON, from the plugin POM it uses the tag <artifactId> for the "name" and <name> for "title".
I like the <name> "Hudson BIRT Charts Plugin", because this will be used as project name in the IDE. This makes it easy to find the project in the list of so many other projects. Also the name "Hudson :: Maven 3 :: Plugin", tells me "Maven3" is a "Plugin" available as module inside the main project "Hudson".
However, I agree with you that the display name "Hudson BIRT Charts Plugin" in the update center has redundant prefix "Hudson" and suffix "Plugin".
To solve this problem we could introduce a POM property called "displayName". Ex
<properties> <displayName>Birt Chart</displayName> </properties>The update center generator would use this property, if available" to fill the JSON attribute "title" or revert to <name> tag.
On 1/26/12 12:40 PM, Henrik Lynggaard Hansen wrote:
Hi I raised an eclipse defect about aligning plugin names (https://bugs.eclipse.org/bugs/show_bug.cgi?id=369713) but I think it warrants wider discussion. As written in the bug report Currently the our naming of plugins (even just within the core) seems a bit "random".Not only is this randomness a bit ugly, it also breaks the natural sorting. examples: Hudson BIRT Charts Plugin JCaptcha Plugin Hudson :: Maven 3 :: Plugin I think we should agree on a preferred naming convention and re-align our own plugins. This convention should be posted on the wiki, so others have a chance to follow it. I suggest we remove both "Hudson" and "plugin" from the name as that information is redundant in the context of the update centre. which would lead to names such as * BIRT Charting * JCaptcha * Maven 3 * Windows slaves I am not sure if this should be done at the source level or in the update centre . " I know that sometimes the name is seen outside the context of plugin centre, and there might be useful to have both "Hudson" and "plugin" in the name, so perhaps an idea was to support reading a property like "hudson.hint.displayname" (same style as the netbeans hints) from the pom.xml and if present use that instead of the normal project name. Best regards Henrik _______________________________________________ hudson-dev mailing list hudson-dev@xxxxxxxxxxx http://dev.eclipse.org/mailman/listinfo/hudson-dev
Back to the top