Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [cdt-dev] Renaming "DSF Disassembly"

So at what point do we pull the old view and rename this one?  I guess we also need to move the prefs from under DSF into just CDT.  What else?

Thankfully, the refactored code has gotten a good amount of testing from various people in the last week, so I think we're close. I'll arbitrarily recommend we yank the old view at the end of next week, baring objections.

Given the view is still in DSF, why would we move the prefs out of the DSP plugin?

So any objections to yanking the old view at the end of the week?  I think it's fine to leave the view in the DSF UI plugin for the reasons you stated.  DSF is now a part of the CDT platform.  Since DSF-GDB is a separate feature, it would be good to move any non-GDB specific stuff out of there.  The Dissassembly*Adaptor classes don't seem like they'll be needed once the old view is gone as org.eclipse.cdt.debug.internal.ui.actions.MoveToLineAdapter would just be updated for the new view.  Hmm.  Actually, that's in cdt.debug.ui which I assume can't have dependencies on dsf.ui.  Ugh.

Back to the top