|[cdt-dev] Renaming "DSF Disassembly"|
I’ve used activities to hide CDI’s Disassembly view. Our product is only shipped with DSF Disassembly view. However, our users don’t know or care about DSF. I’m sure most CDT users (not developers) really know what DSF/CDI is.
At first I thought about hiding the DSF Disassembly view via activities and redefining it with a new name, but that doesn’t work since DisassemblyView class is in an internal package that’s not exported. I assume the community wouldn’t want to export this package? I obviously don’t want to duplicate the code in DisassemblyView and DisassemblyPart.
Does anyone else have this problem? Does it make sense to rename DSF Disassembly to something that would be a bit more meaningful to CDT users? (similar to Memory and Memory Browser views).
Thanks for your help,
Back to the top