[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [tycho-user] Only one of the following can be installed at once

Hi,

The error log must have been heavily edited to the point that it became unclear for example why com.ibm.icu-4.0.1 needs to be installed. Anyway, attached is my understanding of bundle dependencies, and from what it seems apart from Mickael's suggestion, this problem could have been caused by depending on hard-coded version numbers. See Andrew Niefer's blog post for more info: http://aniefer.blogspot.ca/2009/07/composing-and-updating-custom-eclipse.html

Kind regards,
Mikhail Kalkov

Purple Scout AB
Software Developer


From: "Mickael Istria" <mistria@xxxxxxxxxx>
To: tycho-user@xxxxxxxxxxx
Sent: Monday, September 17, 2012 9:54:51 AM
Subject: Re: [tycho-user] Only one of the following can be installed at once

On 09/17/2012 09:45 AM, e92-330cd@xxxxxxxxx wrote:
Hello I have this error:

[ERROR]   Only one of the following can be installed at once: [com.ibm.icu 4.4.2.v20110823, com.ibm.icu 4.2.1.v20100412, com.ibm.icu 4.0.1.v20100112]

[ERROR]   Cannot satisfy dependency: aaaa.eclipse.product 1.0.0.qualifier depends on: bbbb.eclipse.application.feature.feature.group [1.0.0,1.0.1)
[ERROR]   Cannot satisfy dependency: aaaa.eclipse.product 1.0.0.qualifier depends on: cccc.target.standard.feature.feature.group 0.0.0
[ERROR]   Cannot satisfy dependency: bbbb.eclipse.application.feature.feature.group 1.0.0.201209142109 depends on: dddd.eclipse.feature.feature.group [1.0.0.201209142109]
[ERROR]   Cannot satisfy dependency: dddd.eclipse.feature.feature.group 1.0.0.201209142109 depends on: org.eclipse.rcp.feature.group [3.6.2.r362_v20101104-9SAxFMKFkSAqi8axkv1ZjegmiBLY]
[ERROR]   Cannot satisfy dependency: eeee.target.standard.feature.feature.group 2012.4.2 depends on: com.ibm.icu [4.4.2.v20110823]
[ERROR]   Cannot satisfy dependency: org.eclipse.rcp.feature.group 3.6.2.r362_v20101104-9SAxFMKFkSAqi8axkv1ZjegmiBLY depends on: com.ibm.icu [4.2.1.v20100412]

When resolving the dependencies for your product, p2 noticed that you have 2 features depending on different versions of com.ibm.icu. Those features use very restrictive range for this dependency, so that they really require different versions. However, com.ibm.icu bundle is marked as singleton, which means that only one com.ibm.icu can be installed or activated.
So your feature can't work both at the same time.

in ddd.eclipse.feature, you should replace the <plugin id="com.ibm.icu"/> by a <requires><import plugin="com.ibm.icu" .../></requires>. This will make Tycho resolve to "best available" rather than the one it picked-up at build-time.
In general, you must not include something that you don't own and produce as part of the same build. Inclusion is a relationship reserved to the provider, consumers should use requires.

HTH
--
Mickael Istria
Eclipse developer at JBoss, by Red Hat
My blog - My Tweets

_______________________________________________
tycho-user mailing list
tycho-user@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/tycho-user

Attachment: e92-330cd.png
Description: PNG image