[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [platform-ui-dev] enforcing minimum GTK3 release?



On Tue, Sep 4, 2018 at 12:59 PM, Jonah Graham <jonah@xxxxxxxxxxxxxxxx> wrote:
Hi folks,

For a while the Launcher has enforced the minimum version of GTK2 [1]. Has their been any consideration to enforcing a minimum version of GTK3? I regularly have people (customers) come back to me with Eclipse/SWT problems that turn out to probably be down to old versions of GTK (most recent was customer running Fedora Core 18 with GTK 3.6).

For 4.10 SWT will drop GTK 2 support and the min version will be bumped to 3.0. Min version will be raised again for 4.11 - although to which version exactly is to be decided based on the amount of workarounds in the codebase for these older versions and conflicts with support for the upcoming GTK 4.0. If there are bigger conflicts with GTK 4.x support found it might even be the case that SWT 4.10 may have higher than 3.0 GTK version as min requirement but as this work is still in the plan so far the only sure thing is that SWT/Launcher 4.10 will require GTK 3.0 or newer :).
With Gtk 3.22 being already 2 years old and both RHEL and Ubuntu LTS ship with these versions anything else is not realistically being worked on so I expect the rate of min version bumps to enhance until we hit this version as min requirement.
Â

_______________________________________________
platform-ui-dev mailing list
platform-ui-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/platform-ui-dev



--
Alexander Kurtakov
Red Hat Eclipse Team