[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [platform-ui-dev] Unable to build the codehttps://github.com/eclipse/eclipse.platform.ui

Thanks Jonah, and sorry for the trouble!

Dani



From:        Jonah Graham <jonah@xxxxxxxxxxxxxxxx>
To:        "Eclipse Platform UI component developers list." <platform-ui-dev@xxxxxxxxxxx>
Date:        07.06.2018 11:13
Subject:        Re: [platform-ui-dev] Unable to build the code        https://github.com/eclipse/eclipse.platform.ui
Sent by:        platform-ui-dev-bounces@xxxxxxxxxxx




I tried it out and the error means that nothing works.

Use the attached psf file, I have submitted this to Eclipse too: https://git.eclipse.org/r/#/c/124170/

~~~
Jonah Graham
Kichwa Coders Ltd.

www.kichwacoders.com

On 7 June 2018 at 10:00, Jonah Graham <jonah@xxxxxxxxxxxxxxxx> wrote:
Hi Kiran,

It looks like the PSF (project set file) is out of date -- indeed Bug 535285 which was fixed just a few days ago removed the plug-in, but didn't update the PSF file's metadata.

I think you can ignore the error if the rest of the projects imported ok. 

Jonah
 

~~~
Jonah Graham
Kichwa Coders Ltd.

www.kichwacoders.com

On 7 June 2018 at 09:14, Kiran Hariyapuraju <hariyapuraju@xxxxxxxxx> wrote:
Thanks Jonah for sharing the pdf's.

Used "Platform UI_How to Contribute - Eclipsepedia.pdf" to get the code into eclipse and tried to follow the steps.

I am working on windows machince.

Step 1 : Get an Eclipse SDK - Got the SDK (eclipse-SDK-4.7.3a-win32-x86_64) - Completed
Step 2 : Install the tools we use during development - Done
Step 3 : Get the code for Platform UI. Got the error like "Failed to read project description file from location 'C:\Users\khariyap\git\eclipse.platform.runtime\tests\com.google.code.atinject.tck\.project'.
    Failed to read project description file from location 'C:\Users\khariyap\git\eclipse.platform.runtime\tests\com.google.code.atinject.tck\.project'.
    C:\Users\khariyap\git\eclipse.platform.runtime\tests\com.google.code.atinject.tck\.project (The system cannot find the path specified)"


Git has been installed but it does not contain the folder " com.google.code.atinject.tck" but has other folders. Please find the attached images.









Thanks,
Kiran




On Tue, Jun 5, 2018 at 4:12 PM, Jonah Graham <jonah@xxxxxxxxxxxxxxxx> wrote:
Hi Kiran,

Bad timing :-( The wiki is indeed down: http://status.eclipse.org/due to the databases that back the wiki being heavily queried. Try refreshing in a little while and you might be ok. 

As I happen to have the pages open, I will PDF them and send them to you privately in the hope that can help unblock you.

Jonah




~~~
Jonah Graham
Kichwa Coders Ltd.

www.kichwacoders.com

On 5 June 2018 at 11:33, Kiran Hariyapuraju <hariyapuraju@xxxxxxxxx> wrote:
Jonah,

The wiki pages are not accessible.

Thanks,
Kiran

On Tue, Jun 5, 2018 at 2:41 PM, Jonah Graham <jonah@xxxxxxxxxxxxxxxx> wrote:
Hi Kiran,

Did you get the code by download (zip file) or by cloning. The error message you get is because the git repo cannot be found.

I recommend reviewing: https://wiki.eclipse.org/Platform_UI/How_to_Contribute which should show you how to checkout and build Eclipse platform using Eclipse (as opposed to Maven). You may want to look at https://wiki.eclipse.org/Platform_UI/How_to_Contribute/Oomphfor quick start guide that will download IDE and clone all needed git repos.

If you want to use Maven (which I only recommend for automated builds, as opposed to day to day dev) there is https://wiki.eclipse.org/Platform-releng/Platform_Buildthat documents the process in detail.

Jonah


~~~
Jonah Graham
Kichwa Coders Ltd.

www.kichwacoders.com

On 5 June 2018 at 09:48, Kiran Hariyapuraju <hariyapuraju@xxxxxxxxx> wrote:
All,

I got the latest code from https://github.com/eclipse/eclipse.platform.ui

and tried the command "mvn -X clean verify -Pbuild-individual-bundles" and the error is

Failed to execute goal org.eclipse.tycho:tycho-packaging-plugin:1.2.0-SNAPSHOT:build-qualifier (default-build-qualifier) on project org.eclipse.core.commands: No git repository found searching upwards from C:\Users\khariyap\Downloads\eclipse.platform.ui-master\bundles\org.eclipse.core.commands -> [Help 1]

Please do help me on this.

Thanks,
Kiran


_______________________________________________
platform-ui-dev mailing list

platform-ui-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit

https://dev.eclipse.org/mailman/listinfo/platform-ui-dev



_______________________________________________
platform-ui-dev mailing list

platform-ui-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit

https://dev.eclipse.org/mailman/listinfo/platform-ui-dev



_______________________________________________
platform-ui-dev mailing list

platform-ui-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit

https://dev.eclipse.org/mailman/listinfo/platform-ui-dev



_______________________________________________
platform-ui-dev mailing list

platform-ui-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit

https://dev.eclipse.org/mailman/listinfo/platform-ui-dev



_______________________________________________
platform-ui-dev mailing list

platform-ui-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit

https://dev.eclipse.org/mailman/listinfo/platform-ui-dev



[attachment "image.png" deleted by Daniel Megert/Zurich/IBM] [attachment "image.png" deleted by Daniel Megert/Zurich/IBM] [attachment "image.png" deleted by Daniel Megert/Zurich/IBM] [attachment "platformUiProjectsGerrit.psf" deleted by Daniel Megert/Zurich/IBM] _______________________________________________
platform-ui-dev mailing list
platform-ui-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/platform-ui-dev