[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [platform-ui-dev] Unable to build the code https://github.com/eclipse/eclipse.platform.ui

Hi Kiran,

Did you get the code by download (zip file) or by cloning. The error message you get is because the git repo cannot be found.

I recommend reviewing:Âhttps://wiki.eclipse.org/Platform_UI/How_to_ContributeÂwhich should show you how to checkout and build Eclipse platform using Eclipse (as opposed to Maven). You may want to look atÂhttps://wiki.eclipse.org/Platform_UI/How_to_Contribute/Oomph for quick start guide that will download IDE and clone all needed git repos.

If you want to use Maven (which I only recommend for automated builds, as opposed to day to day dev) there is https://wiki.eclipse.org/Platform-releng/Platform_Build that documents the process in detail.

Jonah


~~~
Jonah Graham
Kichwa Coders Ltd.
www.kichwacoders.com

On 5 June 2018 at 09:48, Kiran Hariyapuraju <hariyapuraju@xxxxxxxxx> wrote:
All,

I got the latest code fromÂhttps://github.com/eclipse/eclipse.platform.ui

and tried the command "mvn -X clean verify -Pbuild-individual-bundles" and the error is

Failed to execute goal org.eclipse.tycho:tycho-packaging-plugin:1.2.0-SNAPSHOT:build-qualifier (default-build-qualifier) on project org.eclipse.core.commands: No git repository found searching upwards from C:\Users\khariyap\Downloads\eclipse.platform.ui-master\bundles\org.eclipse.core.commands -> [Help 1]

Please do help me on this.

Thanks,
Kiran



_______________________________________________
platform-ui-dev mailing list
platform-ui-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/platform-ui-dev