[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [platform-ui-dev] Proposal to rename Project menu to Workbenc h

I agree 100%. There is one more problem of this type.
3) Window->Preferences is not intuitive and misleading.
Any of it will be better:
Options->Preferences
Settings->Preferences
Preferences->Customize

-----Original Message-----
From: Simon_Arsenault@xxxxxxx [mailto:Simon_Arsenault@xxxxxxx]
Sent: Friday, December 07, 2001 9:05 AM
To: platform-ui-dev@xxxxxxxxxxx
Subject: Re: [platform-ui-dev] Proposal to rename Project menu to
Workbench



I think just about every person who works mostly with VAJ and VAST want
these menu items rename ;-)  But those who have worked with other IDEs
(like Visual Studio) are quite happy with them (well except for the fact it
was under a menu called Project which gave the wrong impression of scope).

The terms "Build" and "Rebuild All" are well known to developers of other
IDEs. The term "Build" means <<Build resources which have changed since the
last time>> and the term "Rebuild All" means <<Rebuild *all* resources
whether they changed or not since the last time>> (both work within a
defined scope...i.e project or workspace...the location of these menu items
in the ui should make the scope obvious)

True we can come up with "better" names for these actions (at least from
our perspective they would be "better"), but this would confused the user
who is familiar with the other terms Build and Rebuild All (given the scope
of eclipse is more than just VAJ developers, we need to be careful here).
It's sort of like wanting to come up with another word for Paste because it
is not that clear what it does.

From the research I did a few months ago about this "confusion", the main
problems are:

1) The menu name Project was giving the user the wrong impression of scope.
Changing it to Workbench is much better as now we know the actions applies
to everything.

2) Some context menus started using their own variation of "Build" and
"Rebuild All". For example, there is a "Build Project" and "Rebuild
Project". Now people familiar with the other terms are confused. They look
kinda the same but do they do the same? I recommended that on the Project
context menu, we show "Build" and "Rebuild All". It is obvious to the user
the scope is the Project. On other resources, we can show "Project Build"
and "Project Rebuild All" (I'm not going to describe the reasons why this
was needed or if the problem could be solved in other ways - that may come
out in another proposal)

Simon :-)



 

                    Jeff_McAffer@xxxxxxx

                    Sent by:                       To:
platform-ui-dev@xxxxxxxxxxx                      
                    platform-ui-dev-admin@e        cc:

                    clipse.org                     Subject:     Re:
[platform-ui-dev] Proposal to rename    
                                                   Project menu to Workbench

 

                    12/06/2001 05:35 PM

                    Please respond to

                    platform-ui-dev

 

 





Not a committer but could I suggest that the build related entries in this
menu be either (Build, Rebuild) or (Build All, Rebuild All).  The current
set ( Build, Rebuild All) is inconsistent and confusing.  Personally I
would go for the Build All, Rebuild All just to be really clear but I don't
feel strongly.

Jeff





                    Randy_Giffen@xxxxxxx

                    Sent by:                       To:
platform-ui-dev@xxxxxxxxxxx
                    platform-ui-dev-admin@e        cc:

                    clipse.org                     Subject:
[platform-ui-dev] Proposal to
                                                   rename Project menu to
Workbench

                    12/06/2001 01:42 PM

                    Please respond to

                    platform-ui-dev







This is a request for committers to vote.

The workbench menubar currently contains a "Project" menu.
The proposal is to rename this to "Workbench"

The menu items currently contributed to this menu by the ui ("Build" and
"Rebuild All") and jdt ("Open Type") are not scoped to a single project but
rather to all projects in the workspace. This is leading to user confusion.


With the rename to Workbench, menu items such as Search and Preferences can
move to this menu.

Workbench is preferred over Workspace or Projects as items in the menu may
have a scope beyond the workspace (ex. Search scoped to help
documentation).

Workbench is not a new concept and already appears in the ui (ex.
Window>Open Workbench).

Theoretically, some plug-in actions contributed to the Project menu may be
scoped to the selected project. The scope of these actions will be less
apparent to the user after this change. However, there are currently no
known cases of such actions (in SDK or Websphere).

Of course we are just changing the menu label, the menu id will not change
(in fact the menu id for the Project menu is "workbench")



_______________________________________________
platform-ui-dev mailing list
platform-ui-dev@xxxxxxxxxxx
http://dev.eclipse.org/mailman/listinfo/platform-ui-dev




_______________________________________________
platform-ui-dev mailing list
platform-ui-dev@xxxxxxxxxxx
http://dev.eclipse.org/mailman/listinfo/platform-ui-dev