[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[pdt-dev] 1) Patch Install and 2) Artifact Not Found

Hello,

I discovered EclipsePDT just only this morning.  I've read through the
help and documentation for about 1/2 a day now (bye bye sunday), but i
can't get around a few errors.

1) I am using windowsXP Home SP3.
2) I am using eclipse IDE for PHP Developers 1.2.0
3) I am using Eclipse Platform 3.5.0
4) I am using EPP PHP Feature 1.2.0
5) I am using PDT SDK 2.1.0

When I create a PHP project I get the following error as reported in
this archive email message and this bug respectively:
http://dev.eclipse.org/newslists/news.eclipse.tools.pdt/msg03817.html
https://bugs.eclipse.org/bugs/show_bug.cgi?id=280935
(some bug about duplicate build path entries and it references the php
library)

I was able to remove the php5 library during the initial new project
wizard, and then re-add it later from right clicking the PHP Explorer.
However, I would still like to understand the following two behaviors:

1) I downloaded the patch made available from the above site, but I
don't know how to 'install' or 'apply' the patch.  How does one install
a patch?

2)  I instead attempted to upgrade to the PDT SDK 2.1.1 (as there is a
stable release).  However, when I download the all-in-one update site
2.1.1RC3 at
http://www.eclipse.org/pdt/downloads/?showAll=1&hlbuild=S200907140646&project=pdt#S200907140646
I extract the archive to:
C:\Documents and Settings\Budha\Desktop\PDT2_1_1\
and try to install in Eclipse I get the following error:

An error occurred while collecting items to be installed
  session context was:(profile=epp.package.php,
phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Collect,
operand=, action=).
  Artifact not found: osgi.bundle,org.eclipse.php,2.1.1.v20090707-1108.
  C:\Documents and
Settings\Budha\Desktop\PDT2_1_1\plugins\org.eclipse.php_2.1.1.v20090707-1108.jar
(The system cannot find the file specified)
  Artifact not found: osgi.bundle,org.eclipse.php.core,2.1.1.v20090714-1338.
  C:\Documents and
Settings\Budha\Desktop\PDT2_1_1\plugins\org.eclipse.php.core_2.1.1.v20090714-1338.jar
(The system cannot find the file specified)
  Artifact not found:
osgi.bundle,org.eclipse.php.core.parser,2.1.1.v20090707-1108.
  C:\Documents and
Settings\Budha\Desktop\PDT2_1_1\plugins\org.eclipse.php.core.parser_2.1.1.v20090707-1108.jar
(The system cannot find the file specified)
  Artifact not found:
osgi.bundle,org.eclipse.php.debug.core,2.1.1.v20090714-1338.
  C:\Documents and
Settings\Budha\Desktop\PDT2_1_1\plugins\org.eclipse.php.debug.core_2.1.1.v20090714-1338.jar
(The system cannot find the file specified)
  Artifact not found:
osgi.bundle,org.eclipse.php.debug.daemon,2.1.1.v20090707-1108.
  C:\Documents and
Settings\Budha\Desktop\PDT2_1_1\plugins\org.eclipse.php.debug.daemon_2.1.1.v20090707-1108.jar
(The system cannot find the file specified)
  Artifact not found:
osgi.bundle,org.eclipse.php.debug.ui,2.1.1.v20090714-1338.
  C:\Documents and
Settings\Budha\Desktop\PDT2_1_1\plugins\org.eclipse.php.debug.ui_2.1.1.v20090714-1338.jar
(The system cannot find the file specified)
  Artifact not found: osgi.bundle,org.eclipse.php.help,2.1.1.v20090707-1108.
  C:\Documents and
Settings\Budha\Desktop\PDT2_1_1\plugins\org.eclipse.php.help_2.1.1.v20090707-1108.jar
(The system cannot find the file specified)
  Artifact not found:
osgi.bundle,org.eclipse.php.server.core,2.1.1.v20090707-1108.
  C:\Documents and
Settings\Budha\Desktop\PDT2_1_1\plugins\org.eclipse.php.server.core_2.1.1.v20090707-1108.jar
(The system cannot find the file specified)
  Artifact not found:
osgi.bundle,org.eclipse.php.server.ui,2.1.1.v20090707-1108.
  C:\Documents and
Settings\Budha\Desktop\PDT2_1_1\plugins\org.eclipse.php.server.ui_2.1.1.v20090707-1108.jar
(The system cannot find the file specified)
  Artifact not found:
osgi.bundle,org.eclipse.php.source,2.1.1.v20090708-1127-7L7979F8NcJKhKOOA9TaXX.
  C:\Documents and
Settings\Budha\Desktop\PDT2_1_1\plugins\org.eclipse.php.source_2.1.1.v20090708-1127-7L7979F8NcJKhKOOA9TaXX.jar
(The system cannot find the file specified)
  Artifact not found: osgi.bundle,org.eclipse.php.ui,2.1.1.v20090712-1347.
  C:\Documents and
Settings\Budha\Desktop\PDT2_1_1\plugins\org.eclipse.php.ui_2.1.1.v20090712-1347.jar
(The system cannot find the file specified)

Any help would be appreciated.

I look forward to one day using EclipsePDT.

Thanks,
dK
`