[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [pdt-dev] installation using new update manage in 3.4 M6

Hi James,

We currently don't support Eclipse 3.4 in the updates available on the
update site. The update site contains the 1.0.x versions, and only version
1.1.x is planned to support Eclipse 3.4.

For instructions on how to install on Ganymede for now, you can refer to:
http://wiki.eclipse.org/PDT/Installation#Eclipse_3.4_.2F_Ganymede_.2F_PDT_1.
1

Please note that this mailing list is intended for development issues. For
usage problems please refer to the PDT newsgroup in the future
(eclipse.tools.pdt).


Best regards,
Alon


On 14/5/08 4:46 PM, "James Neethling" <Jneethling@xxxxxxxxxxxxx> wrote:

> Hi all,
> 
> I'm looking to build a pdt installation on top of Ganymede M6 (I know
> that M7 is the latest, i've already go M6).
> 
> Using the guidelines on the wiki, I want to install pdt using the new
> update-manager - sorry if this is long-winded. If there is anything
> important that i've left out, let me know.
> 
> some details:
> Os - Ubuntu Hardy
> java -version
> java version "1.5.0_15"
> Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_15-b04)
> Java HotSpot(TM) Server VM (build 1.5.0_15-b04, mixed mode)
> 
> 
> 
> 
> Steps to reproduce:
> 
> 1. remove ~/.eclipse
> 2. remove ~/workspace
> 3. unpack eclipse-jee-ganymede-M6-linux-gtk.tar.gz into /opt/eclipse_3_4_M6
> 4. set ownership:  chown -R james.users /opt/eclipse_3_4_M6/
> 4. run /opt/eclipse_3_4_M6/eclipse
> Eclipse loads (VERY slowly)
> select '/home/james/workspace/' as the workspace.
> 
> 5. click  'workbench'
> 
> I need to set up a network proxy:
> 
> 6. window->preferences -> general -> network connections
> 7. select 'manual proxy', enter in the ip and port.
> 8. click on 'apply' and 'OK'
> 
> 
> Attempt to install from update site:
> 9. help->software updates -> 'available features' -> 'manage sites'
> 10. there are a number of existing sites including:
>    Extension: file:/opt/eclipse_3_4_M6/.pooled
>    Extension: file:/home/james/download/eclipse/20080419/eclipse/.pooled
>    Dropins:/opt/eclipse_3_4_M6/dropins
>    Dropins:/home/james/download/eclipse/20080419/eclipse/dropins
> 
>    Note: /home/james/download/eclipse/20080419/eclipse/ is where I
> downloaded the tar.gz to.
> 
> 11. 'Add' 'http://download.eclipse.org/tools/pdt/updates/' and click 'OK'
>    Eclipse does something, presumably checking/verifying the source.
> 12. Ok
>    The available feasures screen says "pending" and refreshes with lots
> of things to install.
> 13. open 'PDT Features' and select 'PDT Feature - 1.0.2.v20080102-79
> ....' click 'install'
>    eclipse attempts to resolves the dependencies and reports that the
> software I selected may not be valid with the current installation.
> 14. Select 'yes' to review the problems.
> There are unmet dependencies:
> Unsatisfied dependency: [org.eclipse.php_feature.feature.group
> 1.0.2.v20080102-79-7GE7QYGHNGPGY] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.wst.feature.group/[2.0.0,3.0.0)
> Unsatisfied dependency: [org.eclipse.php_feature.feature.group
> 1.0.2.v20080102-79-7GE7QYGHNGPGY] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.wst.feature.group/[2.0.0,3.0.0)
> Unsatisfied dependency: [org.eclipse.php_feature.feature.group
> 1.0.2.v20080102-79-7GE7QYGHNGPGY] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.wst.feature.group/[2.0.0,3.0.0)
> 
> 
> 
> Isn't the new update manager supposed to solve this problem, or is the
> pdt support too new?
> 
> What do I need to get pdt installed?
> 
> Kind Regards,
> James
> 
> 
> 
> 
> _______________________________________________
> pdt-dev mailing list
> pdt-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/pdt-dev