-------- Original Message --------
I'm equally a newcomer to Lua. If you think that the library name
should be "mqtt" to match Lua conventions, then I'm fine with that. I
was just going on the approach we had adopted for the other clients.
I just attempted to push your patch for bug 433411 to the repo, but it
says you have to create a gerrit account first.
"Bringing Lua client to a "Paho 1.0" level is more about drive and
discussions. You are right it does not need tracked task for now. "
I think you misunderstood! I thought that this was the task that *is*
worthy of a task in bugzilla, as the requirements for MQTT 3.1.1 support
for instance are quite detailed.
On 07/03/2014 10:57 AM, Kevin KIN-FOO wrote:
> Le jeu. 03 juil. 2014 11:00:21 CEST, Ian Craggs a écrit :
>> I think the the library name ought to be "paho_mqtt" or some variant
>> that includes "paho". Other potential implementation of mqtt could
>> coexist then, and it this will also make it (reasonably) obvious where
>> the library comes from.
>> I'll create a bug for the task of bringing the Lua client up to the
>> functionality of the other clients. I don't think tasks 2 and 3 are big
>> enough to need a bug - unless you think otherwise.
>> Kevin wrote:
>> Hi Ian,
>> I have 4 in mind:
>> 1. Review my last patch
>> 2. Rename library to "mqtt"
>> 3. Provide a rock for it
>> 4. Make it "Paho 1.0" worthy
>> More details?
>> *2.* As I am writing to use the library you write
>> local mqtt = require 'mqtt_library'
>> As it is only one Lua MQTT client, I think it should be:
>> local mqtt = require 'mqtt'
>> *3.* Being available from package manager will bring more visibility
>> to the library
>> *4.* Lua's small footprint is very suitable for constrained devices, I
>> think it would be nice to reach Paho Major Library level
> About the name, I am strongly advocating for "mqtt". An user would type:
> local mqtt = require 'mqtt'
> As I am writing Paho provides the only Lua MQTT client. If there is an
> other implementation, its first step will be to grab the 'mqtt' name.
> In Lua, usage is taking the shortest meaningful name.
> I do not really get why it is so mandatory to have 'paho' in the name.
> But I am a new comer here.
> We could go for 'pahomqtt'.
> The patch mentioned earlier is attached to Bug 433411.
> Provide a rock is quite easy, but need a .rockspec file, it should be
> stored in the repository. So I think it is task worthy.
> Bringing Lua client to a "Paho 1.0" level is more about drive and
> discussions. You are right it does not need tracked task for now.
>  https://bugs.eclipse.org/bugs/show_bug.cgi?id=433411
icraggs@xxxxxxxxxx IBM United Kingdom
Committer on Paho, Mosquitto