Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[paho-dev] Lua client work items


I think the the library name ought to be "paho_mqtt" or some variant that includes "paho". Other potential implementation of mqtt could coexist then, and it this will also make it (reasonably) obvious where the library comes from.

I'll create a bug for the task of bringing the Lua client up to the functionality of the other clients. I don't think tasks 2 and 3 are big enough to need a bug - unless you think otherwise.


Kevin wrote:

Hi Ian,

I have 4 in mind:

     1. Review my last patch
     2. Rename library to "mqtt"
     3. Provide a rock for it
     4. Make it "Paho 1.0" worthy

More details?

*2.* As I am writing to use the library you write

     local mqtt = require 'mqtt_library'

As it is only one Lua MQTT client, I think it should be:

    local mqtt = require 'mqtt'

*3.* Being available from package manager will bring more visibility
to the library

*4.* Lua's small footprint is very suitable for constrained devices, I
think it would be nice to reach Paho Major Library level

Ian Craggs
icraggs@xxxxxxxxxx                 IBM United Kingdom
Committer on Paho, Mosquitto

Back to the top