You are looking a p2 metadata. p2 is a provisioning technology. It does use OSGi like properties. The =1.8 is fine because at runtime any JDK >= 1.8 *provides* 1.8 implicitly. So the bundle says "I need 1.8" and the runtime says "My JDK is compatible to 1.8".
Sorry to ask again, but I am new on this ML and not sure if I made a mistake, posting something that was so far ignored. Should I rather contact the Ant bundle maintainer(s) directly in some way? If so, would you mind telling me how? Otherwise, if my message contains insufficient information, would you please guide me towards what the delta is you need to investigate my issue?
Alexander Kriegisch schrieb am 15.04.2021 15:32 (GMT +07:00):
Disclaimer: I have never used OSGi before and am just trying to find out
why the build of a product I am interested in is not working.
Firstly, I am sorry to cross-post both in the (mostly inactive)
community forum (moderated, not published yet) and here.
The situation is as follows:
** I need to upgrade a product using Eclipse OSGi bundles.
** One upgraded bundle contains Java 11 class files, i.e. I need to
build running JDK 11+ for obvious reasons.
** Other than the compiler recognising the byte code version, I use
not Java 9+ features at all, my build target is 1.8.
** One indirectly required plugin Tycho pulls is Apache Ant from
Orbit. The concrete version resolved is 1.10.9.v20201106-1946.
** According to , the Ant bundle requires an exact match on Java
version 1.8 according to the 'requiredProperties' tag.
** I do not understand this restriction, as Ant itself just requires
Java 1.8+ to run, I use it in other projects with up to Java 16
without any issues.
Could someone please fix the bundle descriptor to '>=1.8' instead of
'=1.8'? Otherwise neither I nor anyone else can ever build anything
requiring Ant with Java 9+.
orbit-dev mailing listorbit-dev@xxxxxxxxxxx
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/orbit-dev