Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[] Pivot to AS renaming

Hi Adolfo

In principle we agreed that we should rename Pivot to AS but it's not that simple.

For my recent CSE commit of the codegen plugin I converted about 800 "Pivot"s to "AS" leaving about 200, mostly in import paths, or PivotUtil of API methods.

"Pivot" in a method name such as "getPivotResource" can be renamed as "getASResource"

"pivot" as a model element name can be renamed as "ast" and consequently "get/reset/setPivot" renames as "get/reset/setAst".

I'm not happy renaming "org.eclipse.ocl.examples.pivot" as "". Perhaps we should use "org.eclipse.ocl.oclas" which helps later.


"pivot" as a URI protocol/scheme seems to have been an aberation that is going away as I fix loading/saving of pivot files

".pivot" as a file extension does not look good renamed to ".as", ".oclas" is better and less likely to conflict with other applications

A QVTi CS text file: "*.qvti"
A QVTi CS XMI file: "*.qvti.xmi"
A QVTi AS XMI file: "*.qvti.oclas"

We need the double extension on the AS so that a reference to Ecore.ecore.oclas creates a Pivot Resource that loads Ecore.ecore and performs the Ecore2Pivot conversion. Similarly a reference such as will load and convert. (This was the original idea behind a "pivot:" scheme, but a ".oclas" extension is simpler and does not need any name mangling to convert to pivot://http/

The extension doesn't have to be ".oclas", but trying to use ".xmi" for the AS (and something else for CS) will give all sorts of obscure conflicts with other applications that do not consistently register *.xmi for content-type only resolution.

Since *.pivot is not usefully saveable/loadable at present I can probably change to *.oclas while fixing save/load.

I may introduce some synonym classes/methods e.g. getASType() for MetaModelManager.getPivotType() to ease gradual migration.



Back to the top