[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[jgit-dev] Fwd: NPE in ResourcePropertyTester.hasGerritConfiguration()

forwarding to the list

---------- Forwarded message ----------
From: Matthias Sohn <matthias.sohn@xxxxxxxxx>
Date: Sun, Jan 19, 2014 at 11:54 PM
Subject: Re: [jgit-dev] NPE in ResourcePropertyTester.hasGerritConfiguration()
To: Robert von Burg <eitch@xxxxxxxxxxx>


On Sun, Jan 19, 2014 at 10:51 AM, Robert von Burg <eitch@xxxxxxxxxxx> wrote:
Hi

On 18 January 2014 23:26, Matthias Sohn <matthias.sohn@xxxxxxxxx> wrote:
> On Sat, Jan 18, 2014 at 12:26 PM, Robert von Burg <eitch@xxxxxxxxxxx> wrote:
>>
>> Hi guys
>>
>> I am constantly having NPEs when working with my GIT projects in
>> Eclipse. The NPE is generated with egit tries to see if my repository
>> has Gerrit Configuration. What can i do to fix this?
>>
>> This is an excerpt of the stack trace:
>> !ENTRY org.eclipse.jface 4 2 2014-01-18 12:21:27.703
>> !MESSAGE Problems occurred when invoking code from plug-in:
>> "org.eclipse.jface".
>> !STACK 0
>> java.lang.NullPointerException
>> at
>> org.eclipse.egit.ui.internal.ResourcePropertyTester.hasGerritConfiguration(ResourcePropertyTester.java:162)
>> at
>> org.eclipse.egit.ui.internal.repository.RepositoriesViewLabelProvider.getImage(RepositoriesViewLabelProvider.java:116)
>> at
>> org.eclipse.ui.internal.navigator.extensions.SafeDelegateCommonLabelProvider.getImage(SafeDelegateCommonLabelProvider.java:106)
>> at
>> org.eclipse.ui.internal.navigator.NavigatorContentServiceLabelProvider.findImage(NavigatorContentServiceLabelProvider.java:197)
>
>
> what's the content of your repository's .git/config ?

That was the problem. I had a property "branch.master.push=master".
After i removed that, the NPE went away. I remember putting it there
for a push problem. But it still seems to work.

I filed https://bugs.eclipse.org/bugs/show_bug.cgi?id=426067Âto track this problem and pushed a fix for review

--
Matthias