[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [jdt-dev] Removing Java 11 marketplace solution and update site

Hi Philippe

Both bugs are resolved in 4.11.

Did you maybe switch the Java version when switching to the new Eclipse versions? If so, try with Java 8.

Dani



From:        "Philippe Cadé" <philippe.cade@xxxxxxxxx>
To:        "Eclipse JDT general developers list." <jdt-dev@xxxxxxxxxxx>
Date:        27.03.2019 18:00
Subject:        Re: [jdt-dev] Removing Java 11 marketplace solution and update site
Sent by:        jdt-dev-bounces@xxxxxxxxxxx




Dani,

With 4.11, we have error messages "The package xxx is accessible from more than one module: <unnamed>, xxx" as described in bugs 536928 and 545621. It looks like we need to sort out our dependencies first and this will most likely take some time as some of the libraries we are using need to be updated first.

With 4.10, we have an error saying "The project was not built since its build path is incomplete. Cannot find the class file for java.util.ArrayList. Fix the build path then try building this project", we haven't opened a bug yet, still figuring out what is happening here.

Removing this update site forces us to move to an Eclipse with a now stricter compiler before we are ready to do so. Right now, we just want to be able to continue deploying a working Eclipse 4.9 via Oomph using our current setup.

Philippe


On Wed, Mar 27, 2019 at 2:32 PM Daniel Megert <daniel_megert@xxxxxxxxxx> wrote:
Hi Philippe

>
We are not ready to move to a newer Eclipse version yet because of some trouble compiling our software with 2018-12 and 2019-03. 

What's the problem? Did you open a bug report or is it an issue on your side?


Dani




From:        
"Philippe Cadé" <philippe.cade@xxxxxxxxx>
To:        
"Eclipse JDT general developers list." <jdt-dev@xxxxxxxxxxx>
Date:        
27.03.2019 13:05
Subject:        
Re: [jdt-dev] Removing Java 11 marketplace solution and update site
Sent by:        
jdt-dev-bounces@xxxxxxxxxxx




Hello Jay,

This is now a problem for us. We are still on Eclipse 2018-09 and we were using the 
https://download.eclipse.org/eclipse/updates/4.9-P-buildsupdate site to add Java 11 support.

We are not ready to move to a newer Eclipse version yet because of some trouble compiling our software with 2018-12 and 2019-03. 

Since Java 11 is a LTS, wouldn't it make sense to keep it around? Or can we get Java 11 support for 2018-09 from another source?

Thanks
Philippe

On Tue, Mar 19, 2019 at 5:36 AM Jayaprakash Arthanareeswaran <
jarthana@xxxxxxxxxx> wrote:
Hello all,

Being on the cusp of Java 12 release, we will be removing this outdated marketplace entry and the corresponding update sites this week.

Regards,
Jay

_______________________________________________
jdt-dev mailing list

jdt-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit

https://www.eclipse.org/mailman/listinfo/jdt-dev_______________________________________________
jdt-dev mailing list

jdt-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit

https://www.eclipse.org/mailman/listinfo/jdt-dev


_______________________________________________
jdt-dev mailing list

jdt-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit

https://www.eclipse.org/mailman/listinfo/jdt-dev_______________________________________________
jdt-dev mailing list
jdt-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/jdt-dev