Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [higgins-dev] Can the JNDI context provider use Rhino1.6.1 or 1.6.2 rather than 1.6.5?

is old, dating from

     Mary are you asking that we temporary state we can use 1.6R1 or 1.6R2 until legal catches up or are you asking us to move back to these crusty versions and remove 1.6R5 from the eclipse legal queue so we can reduce their workload?    In general with all of the updates we have been discussing I hope we aren't accepting the old versions of dependancies and then removing the newer versions from ipzilla.
     During testing months ago the scripts we were using didn't work with 1.6R2  of Rhino, and made it much more difficult for deployers because _javascript_ stacks and errors were not fully reported.  
Rhino 1.6R22005-09-19 and missing the following bug fixes  to get to 1.6R3.    1.6R4 was a single bug fix , and 1.6R5 was updating the code to the mozilla tri-license.    As of the end of July Rhino download links have changed and 1.6.5 is now considered old and must be accessed from the download archives with 1.6R6 being the new preferred supported version.   
     It won't be long before we may want to use 1.6R6, it has better _javascript_ 1.5 language support, fixes so we can call back into java var arg functions (audit and logging), better warning and error messages to simplify debugging, fewer external dependancies, and numerous bug fixes.   If this is a multi year process to get approved then I may want to start it now anticipating that I might use it.
From: "Mary Ruddy" <mary@xxxxxxxxxxxxxxxxx>
To: "'Higgins (Trust Framework) Project developer discussions'" <higgins-dev@xxxxxxxxxxx>
Date: 7/31/2007 1:16 PM
Subject: RE: [higgins-dev] Can the JNDI context provider use Rhino1.6.1 or 1.6.2 rather than 1.6.5?

When Eclipse wrote 1.6.2 they meant 1.6R2  (CQ 78 for approval of 1.6.2
references the 1.6R2 code.) Let me know if 1.6R2 (or 1.6R1)works. 


-----Original Message-----
From: higgins-dev-bounces@xxxxxxxxxxx
[mailto:higgins-dev-bounces@xxxxxxxxxxx] On Behalf Of Tom Doman
Sent: Tuesday, July 31, 2007 11:21 AM
To: 'Higgins (Trust Framework) Project developer discussions'
Subject: Re: [higgins-dev] Can the JNDI context provider use Rhino1.6.1
or 1.6.2 rather than 1.6.5?


I still have the same "." vs. "R" question I outlined here in June:  Are
they interchangeable?  ie. 1.6R5 == 1.6.5.  As I described before, the
download site ( uses "R".


>>> "Mary Ruddy" <mary@xxxxxxxxxxxxxxxxx> 7/24/2007 9:49 AM >>>

Because of the backlog of code that needs to be reviewed for Higgins by
Eclipse legal, we need to maximize reuse (use versions that have already
been approved). Rhino 1.6.1 and 1.6.2 have already been approved.
Please verify that one of these works for you or that you could make it

higgins-dev mailing list

higgins-dev mailing list

Back to the top