|Re: [ecf-dev] RemoteServiceAdmin implementation
Hi Markus, On 12/5/2010 10:23 AM, Markus Alexander Kuppe wrote:
On 12/03/2010 04:37 PM, Scott Lewis wrote:For RSA, I was thinking of changing the name of this concept from 'container finder' to 'container selector'...just to be slightly clearer...and indeed reusing much of the existing code...since the function is essentially the same for RSA as it was/is for the existing remote services implementation.Couldn't we keep to old interface names and thus keep existing implementations compatible?
Ok...so two things:First...it's going to be fairly difficult to keep existing implementations (of IHostContainerFinder and IProxyContainerFinder) completely compatible...because some of the RSA-defined data structures (e.g. EndpointDescription) and interfaces (e.g. RemoteServiceAdmin) imply different method signatures for the 'container finder/selector' semantics.
Second...because of the first issue with compatibility it seems to me it might be a good idea to rename the interface from IHostContainerFinder to IHostContainerSelector with the move to RSA. I'm not particularly married to IHostContainerSelector, however, so if others disagree about the this naming (i.e. prefer 'container finder' to 'container selector'...or prefer something else entirely), then please bring it up for discussion and propose alternatives.
Might be good to have specific discussions about naming, etc on the RSA bug  as well. I'm open to changes in naming (and it's a good time to discuss it...since nothing about RSA impl is etched in stone at the moment).
Markus _______________________________________________ ecf-dev mailing list ecf-dev@xxxxxxxxxxx https://dev.eclipse.org/mailman/listinfo/ecf-dev
Back to the top