Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [ecf-dev] Naming conventions / API guidelines

I actually don't recall ever having "provisional" in any form in package names in the Eclipse project.  Not saying they weren't there, just I don't remember having any and certainly we never had them in the lower level runtime areas.  Personally I don't see any use in distinguishing between internal and internal provisional.  Both carry the same level of risk and uncertainty for consumers.  It may be relevant to direct people towards stuff that you think will perhaps someday be API but that seems somewhat tenuous to me.  


"Erkki Lindpere" <villane@xxxxxxxxx>
Sent by: ecf-dev-bounces@xxxxxxxxxxx

11/04/2006 05:03 AM

Please respond to
"Eclipse Communication Framework (ECF) developer mailing list." <ecf-dev@xxxxxxxxxxx>

"Eclipse Communication Framework (ECF) developer mailing list." <ecf-dev@xxxxxxxxxxx>
[ecf-dev] Naming conventions / API guidelines

It seems the Eclipse naming conventions have changed a bit recently?

I seem to remember (maybe wrongly?) that *.provisional.* was used in
package names for provisional API, but this doesn't seem to be the
case any more when reading the wiki entry .
Now there seems to be a new convention of using
*.internal.provisional.* for "experimental" code that is intended to
become public at some point.

I wonder what I should use for the core BBAPI that should eventually
become public? Maybe it should be "internal.provisional" in 1.0 and
become public in a later release?
ecf-dev mailing list

Back to the top