|Re: [ecf-dev] Naming conventions / API guidelines|
Erkki Lindpere wrote:
It seems the Eclipse naming conventions have changed a bit recently? I seem to remember (maybe wrongly?) that *.provisional.* was used in package names for provisional API, but this doesn't seem to be the case any more when reading the wiki entry http://wiki.eclipse.org/index.php/Provisional_API_Guidelines . Now there seems to be a new convention of using *.internal.provisional.* for "experimental" code that is intended to become public at some point. I wonder what I should use for the core BBAPI that should eventually become public? Maybe it should be "internal.provisional" in 1.0 and become public in a later release?
No, I don't think that it should be marked "internal.provisional".As I read the section "Package Naming" it has: "The "internal.provisional" naming convention can be used, but is not required, to separate code that may become API in the future from other internal code within the internal package namespace"
Based upon this, I think that the "internal.provisional" package name is really intended to be for code that is expected to be internal, but *may* become API in the future...rather than code that is expected to be API, and is simply provisional because it's not to 1.0 yet (which is the case with all ECF code at the moment).
My suggestion is that you make API packages exported and name them as "API packages", name the packages that you expect to be internal "internal.*", and only use "internal.provisional" for stuff that looks to you like internal code that *could* go to API at some point in the future.
_______________________________________________ ecf-dev mailing list ecf-dev@xxxxxxxxxxx https://dev.eclipse.org/mailman/listinfo/ecf-dev
Back to the top