|[ecf-dev] Naming conventions / API guidelines|
It seems the Eclipse naming conventions have changed a bit recently? I seem to remember (maybe wrongly?) that *.provisional.* was used in package names for provisional API, but this doesn't seem to be the case any more when reading the wiki entry http://wiki.eclipse.org/index.php/Provisional_API_Guidelines . Now there seems to be a new convention of using *.internal.provisional.* for "experimental" code that is intended to become public at some point. I wonder what I should use for the core BBAPI that should eventually become public? Maybe it should be "internal.provisional" in 1.0 and become public in a later release?
Back to the top