[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cross-project-issues-dev] Guava version conflicts

According to "Luna repo reports" project in Luna are currently using everything from "10" to "14"

com.google.guava
                11.0.2.v201303041551
                14.0.1.v20130703-1129
                10.0.1.v201203051515
                12.0.0.v201212092141


(And version 14 never even made it into Orbit they release so often!?)

But, I've just promoted a new I-build from Orbit that has version 15.

http://download.eclipse.org/tools/orbit/downloads/drops/I20140224171915/

I suggest everyone using one of these older versions try soon (by M6 at latest) to see if you can move to version 15 for Luna.
If you can, or can not, please update Bug 427862. (And, sorry, I personally don't know enough about it to know what's different ... if there have
been changes in APIs or behavior, or simply additions ... but, your reports may help understand those issues better).

I am encouraging this, not simply to use "the same version" (though that doesn't hurt) but there has been improvements made in version 15 that should improve the situation for even for future changes.

Thanks,





From:        Ed Willink <ed@xxxxxxxxxxxxx>
To:        Cross project issues <cross-project-issues-dev@xxxxxxxxxxx>,
Date:        02/25/2014 02:55 AM
Subject:        [cross-project-issues-dev] Guava version conflicts
Sent by:        cross-project-issues-dev-bounces@xxxxxxxxxxx




Hi

Problems and solutions regarding class loader conflicts between Guava
versions are being discussed on

https://bugs.eclipse.org/bugs/show_bug.cgi?id=427862#c18

Comment 18 contains the latest bad scenario.

If you use Guava you should follow this bug.

    Regards

        Ed Willink

_______________________________________________
cross-project-issues-dev mailing list
cross-project-issues-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev