Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cdt-dev] Support for "target-detach" and "target-disconnect"

Can you move this discussion in the bugzilla report? Just a thought...

On Thu, Apr 15, 2010 at 1:03 PM, Marc Khouzam <marc.khouzam@xxxxxxxxxxxx> wrote:
>> -----Original Message-----
>> From: cdt-dev-bounces@xxxxxxxxxxx
>> [mailto:cdt-dev-bounces@xxxxxxxxxxx] On Behalf Of Mikhail Khodjaiants
>> Sent: April-15-10 12:58 PM
>> To: cdt-dev@xxxxxxxxxxx
>> Subject: Re: [cdt-dev] Support for "target-detach" and
>> "target-disconnect"
>> > My point was that having 'disconnect' on the toolbar, for GDB,
>> > doesn't not seem as useful as having 'detach'.
>> > Are we really forced to have GDB's 'disconnect' on the toolbar,
>> > just because the JDT/platform has named it 'disconnect'.
>> >
>> > Is that the only reason that we don't instead have GDB's
>> > disconnect in the view menu?
>> >
>> I agree. But "Disconnect" is contributed by the platform and has been
>> there from the very beginning. I don't think we will be able
>> to convince
>> the platform team to remove it from the toolbar.
> But it's just the name 'disconnect' that is the problem.
> wouldn't be ok to have it be a 'disconnect' for JDT, but a 'detach'
> for CDT?
> The reason that motivates your change is, as per your first email:
> "Currently both GDB-based implementations use the "Disconnect" action of the Debug
>  view for sending the "detach" command to GDB. This is misleading because there is
>  the "disconnect" command in GDB.""
> Which is just the naming of the command, no?
> I'm having trouble accepting that we are going to make this change because
> the names don't match.  Did users of CDT complain about the situation?_______________________________________________
> cdt-dev mailing list
> cdt-dev@xxxxxxxxxxx

Back to the top