[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cbi-dev] javax.security.sasl dependency error M5


On 12-03-15 10:35 AM, Thanh Ha wrote:
Thanks Igor,

I set the executionEnvironment in eclipse-parent/pom.xml to J2SE-1.5 and the
build seems to get a little further now. I had a discussion with Andrew
regarding what the minimum build environment should be and he pointed me to
the target environments page
http://www.eclipse.org/projects/project-
plan.php?projectid=eclipse#target_environments

It seems to be 1.6 from what I can tell so I set it to JavaSE-1.6 for now.


Don't change executionEnvironment in the parent pom. It controls default execution environment for all projects and I believe many still target earlier eclipse versions.


For my knowledge, I noticed in the existing
<executionEnvironment>?J2SE-1.4</executionEnvironment>  setting there was a ?
prefixed. What does this symbol represent in pom files?


"?" means "use configuration from osgi specific metadata if available".


The build is now throwing another dependency error (see attached log) regarding org.eclipse.equinox.console.jaas.fragment.source. I was able to find the console.jaas.fragment in /rt.equinox.bundles/bundles and it even has the pom files. Any idea on why this might be happening?

I did noticed that in the previous version of the
org.eclipse.equinox.core.sdk's feature.xml file. The console.jaas.fragment
plugin was not declared but in the M5 version of this same file it now exists.
Could this be a build dependency reordering issue?



org.eclipse.equinox.console.jaas.fragment.source does not have any sources afaict, at least it did not in M4. Tycho does not generate source bunldes for bundles without sources. You need to remove it from org.eclipse.equinox.core.sdk feature.xml.

Thanks,


Thanh



-----Original Message-----
From: Igor Fedorenko<igor@xxxxxxxxxxxxxx>
Sent: March 14, 2012 10:03 PM
To: cbi-dev@xxxxxxxxxxx
Cc:
Subject: Re: [cbi-dev] javax.security.sasl dependency error M5

The build is configured to use J2SE-1.4 execution environment by default
(see<executionEnvironment>  configuration element in the parent pom.xml
file), which I believe does not provide javax.security.sasl package. Try
forcing J2SE-1.5 execution environment for the failing feature build
using something like this

...
       <plugin>
          <groupId>org.eclipse.tycho</groupId>
          <artifactId>target-platform-configuration</artifactId>
          <configuration>
            <executionEnvironment>J2SE-1.5</executionEnvironment>
          </configuration>
        </plugin>
...

--
Regards,
Igor

On 12-03-13 11:45 AM, Thanh Ha wrote:
Hi Everyone,

I decided to do a clean rebase of M5 with the latest CBI-M4 and am having
some
issues with dependencies (see attached error log). Related to
javax.security.sasl.

I'm a little stumped on this issue and am not sure what I should look at.
Any
ideas on what could be causing this issue?

Thanks,


Thanh



_______________________________________________
cbi-dev mailing list
cbi-dev@xxxxxxxxxxx
http://dev.eclipse.org/mailman/listinfo/cbi-dev
_______________________________________________
cbi-dev mailing list
cbi-dev@xxxxxxxxxxx
http://dev.eclipse.org/mailman/listinfo/cbi-dev



_______________________________________________
cbi-dev mailing list
cbi-dev@xxxxxxxxxxx
http://dev.eclipse.org/mailman/listinfo/cbi-dev