[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [wtp-dev] XSL formatter stops formatting


Sorry. I may have spoken too soon here. The charcter I had experience with was ...

This should of course mean tha   is legal....

My bad.

/frode

PS. Legal characters are :

Character Range
                                                                                                                                                                              
 [2]    Char        #x9 | #xA | #xD | [#x20-#xD7FF] | [#xE000-#xFFFD] | [#x10000-#x10FFFF]                   /* any Unicode character, excluding the surrogate blocks, FFFE,  
              ::=                                                                                            and FFFF. */                                                     
                                                                                                                                                                              
                                                                                                                                                                              

and clearly #A0 is withing this range...






                                                                                                                        
             frode@xxxxxxxxx                                                                                            
             Sent by:                                                                                                   
             wtp-dev-bounces@xxxxxxxxxxx                                                                             To 
                                                         "General discussion of project-wide or architectural issues."  
                                                         <wtp-dev@xxxxxxxxxxx>                                          
             28.01.2009 22:42                                                                                        cc 
                                                                                                                        
                                                                                                                Subject 
                      Please respond to                  Re: [wtp-dev] XSL formatter stops formatting                   
             "General discussion of project-wide                                                                        
                  or architectural issues."                                                                             
                    <wtp-dev@xxxxxxxxxxx>                                                                               
                                                                                                                        
                                                                                                                        
                                                                                                                        






â&#xA0; is not a legal character to have inside any XML, so that the formatter stops formatting when hitting this
charachter is no surprise. Any other well-behaved xml-parser will also stop parsing the XML when hitting this.

Just try to open the file in any browser, and it will report illegal character... IE will actually render the most of
it, but will have 'error'-comment down to the left. Firefox will not display it at all.

If You should try to create a DOM-tree with Jdom, and try to insert this character inside any element it would throw an
exception at You.

In short; You will have to avoid this charcter inside any XML-document..

/frode






             "Campbell, Lance"
             <lance@xxxxxxxxxxxx>
             Sent by:                                                                                                To
             wtp-dev-bounces@xxxxxxxxxxx                 <wtp-dev@xxxxxxxxxxx>
                                                                                                                     cc

             28.01.2009 18:07                                                                                   Subject
                                                         [wtp-dev] XSL formatter stops formatting

                      Please respond to
             "General discussion of project-wide
                  or architectural issues."
                    <wtp-dev@xxxxxxxxxxx>






The XSL formatter stops formatting when it encounters â&#xA0;â.  This would seem like a trivial issue but we have very
complex XSLs.  If I cannot get around this issue I donât think I will be able to use this tool for XSL editing.  Is
there something I can do to resolve this issue in preferences?  Am I posting this issue to the correct place?

Thanks,

Lance Campbell
Project Manager/Software Architect
Web Services at Public Affairs
University of Illinois
217.333.0382
http://webservices.uiuc.edu
 _______________________________________________
wtp-dev mailing list
wtp-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/wtp-dev
_______________________________________________
wtp-dev mailing list
wtp-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/wtp-dev