Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[wtp-dev] Fw: [wtp-releng] Important notice/action for this week's 1.5.1 M build: pre-req plugin version ranges.

Sorry for duplicate send .. I meant to send this to wtp-dev ... I think its important enough.

----- Forwarded by David M Williams/Raleigh/IBM on 08/01/2006 03:21 PM -----
David M Williams/Raleigh/IBM@IBMUS
Sent by: wtp-releng-bounces@xxxxxxxxxxx

08/01/2006 03:15 PM

Please respond to
Webtools releng discussion list <wtp-releng@xxxxxxxxxxx>

" wtp-releng" <wtp-releng@xxxxxxxxxxx>
[wtp-releng] Important notice/action for this week's 1.5.1 M build: pre-req plugin version ranges.

I'd like to ask all teams to take on a "" task this week.  (I'll give the reason why, at the end of the note).

You may recall that in 1.5 "end game" we (ok, it was just me) quickly assigned version ranges to all our pre-req'd plugins. For example,

: org.eclipse.core.runtime;bundle-version="[3.2.0,3.3.0)",

I picked the "conservative" range
[3.2.0,3.3.0) so we would work with any maintenance fixes, but,
being conservative about working with 3.3 and above. (the open parenthesis means not inclusive) since I didn't
know the state of all our plugins API cleanliness.

Its actually only in those cases that we use "non API" that we should be so conservative, but me not knowing,
and us being in a hurry, did the safest thing. If we used only API from a pre-req, we can (and should) use a wide range, such as

: org.eclipse.core.runtime;bundle-version="[3.2.0,4.0.0)",

So, now's a good time for plugin/component owners to take responsibility for their pre-req plugins and adjust the version ranges,
if appropriate. Please don't touch them, if you do not know if its safe, but, if you know that you do not use non-API in a pre-req'd
plugin, then you can safely spec a wide range.

Normally, we would not want to do this in a maintenance release (and, again, please do so only if you know its completely safe)
but, I think we should allow this opportunity for the following reason(s).

I know several teams have not and do not want to "split stream". But, for us to build/run with the Eclipse 3.3 stream we either have
to adjust many of our pre-req version ranges, or, you will have to split stream (so, 1.5.1 stream stays the same range, but the head
stream can have widened ranges). I checked, and this impacts about a third of our plugins. You can check yourself by making
a target from a recent I-build and, after re-building, looks for "unsatisfied constraint" errors (or warnings) n the problems view.

So, this request is only applicable if you can do it safely and if you do not want to split stream.

Please "fix" any ranges you want to (that are safe :) for THIS week in our 1.5.1  builds, and then any "tight ranges"
that remain NEXT week will have to be split streamed. While we moved "up" to a recent maintenance build from the Eclipse Project,
we can not move up to a recent 3.3. I-build until we get this resolved.

(And, if there's any doubt, I'd still encourage you to be safe, and simply split stream (split steams not so bad :)
... but .... plugin owners ... its now your responsibility to go one way or the other).

Suggestions, comments, questions are welcome ... but, pay now or pay later :)

Thanks all.

wtp-releng mailing list

Back to the top