|Re: [tycho-user] Tycho migrate version from 2.2 to 2.4|
Just guessing that this may be related to the resolver changes in 2.3: https://wiki.eclipse.org/Tycho/Release_Notes/2.3#Official_Equinox_Resolver_used_for_dependency_resolution_.28stricter_and_can_produce_errors_for_split_packages.29
Mit freundlichen Grüßen / Best regards
Von: tycho-user <tycho-user-bounces@xxxxxxxxxxx>
Im Auftrag von Antonio Garmendía
Currently, I built my jars using Tycho 2.2 and at this moment it works fine. However, I was trying to migrate to version 2.4, but the following error arises:
[ERROR] Unresolved requirement: Require-Bundle: org.jboss.forge.roaster.roaster-api; bundle-version="2.23.0"
Since I am using Apache Aries I do not know if I am missing something. It is weird (at least for me) because it works with version 2.2. In addition, I tested also with Tycho 2.3 and the same error arises.
Any hints? Should I make a minimal example?
Thanks in advance.
Back to the top