Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[tycho-user] Tycho migrate version from 2.2 to 2.4

Hi all,

Currently, I built my jars using Tycho 2.2 and at this moment it works fine. However, I was trying to migrate to version 2.4, but the following error arises:

[ERROR]   Unresolved requirement: Require-Bundle: org.jboss.forge.roaster.roaster-api; bundle-version="2.23.0"
[ERROR]     -> Bundle-SymbolicName: org.jboss.forge.roaster.roaster-api; bundle-version="2.23.0.Final"; singleton:="true"
[ERROR]        org.jboss.forge.roaster.roaster-api [1]
[ERROR]          Unresolved requirement: Require-Capability: osgi.extender; filter:="(osgi.extender=osgi.serviceloader.processor)"
[ERROR] -> [Help 1]

Since I am using Apache Aries I do not know if I am missing something. It is weird (at least for me) because it works with version 2.2. In addition, I tested also with Tycho 2.3 and the same error arises.

Any hints? Should I make a minimal example?

Thanks in advance.

Kind regards,

Back to the top