Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [tycho-user] Force specific updatesite to resolve dependencies

great, thanks a lot!



On 11/19/11 7:20 PM, Igor Fedorenko wrote:
If the two copies of the dependency have exactly the same version, then
the only way to use the desired version is to remove indigo repository
from pom.xml.

If the version is different, then you can force Tycho 0.14 use specific
version using target platform configuration as described in [1]. Do note
that this is still work in progress, so process with caution.

[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=363331

--
Regards,
Igor

On 11-11-19 1:14 PM, Robert Gr√ľndler wrote:
Hi,

my plugin has a dependency which is available in the indigo update site,
however it will only compile with a development
snapshop of the plugin which is hosted in another updatesite.

When the tycho build runs and the dependencies are resolved, tycho keeps
using the indigo updatesite to resolve it, hence
the build fails.

Is there a way to force a specific updatesite if multiple repositories
for the same dependencies are available?

Here's my master pom.xml (the github updatesite should be the one which
needs to be used to resolve dependencies):

<?xml version="1.0" encoding="UTF-8"?>
<project>
<modelVersion>4.0.0</modelVersion>
<groupId>com.dubture.twig</groupId>
<artifactId>parent</artifactId>
<version>1.0.90.qualifier</version>
<packaging>pom</packaging>
<modules>
<module>com.dubture.twig.core</module>
<module>com.dubture.twig.parser</module>
<module>com.dubture.twig.ui</module>
</modules>

<properties>
<tycho-version>0.13.0</tycho-version>
</properties>

<repositories>
<repository>
<id>github</id>
<layout>p2</layout>
<url>http://pulse00.github.com/Twig-Eclipse-Plugin/</url>
</repository>
<repository>
<id>indigo</id>
<layout>p2</layout>
<url>http://download.eclipse.org/releases/indigo</url>
</repository>
</repositories>

<build>
<plugins>
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-maven-plugin</artifactId>
<version>${tycho-version}</version>
<extensions>true</extensions>
</plugin>
</plugins>
</build>

</project>




_______________________________________________
tycho-user mailing list
tycho-user@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
tycho-user@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/tycho-user



Back to the top