[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [tycho-dev] ECF: HTTP connection reuse

ah. found it now

https://bugs.eclipse.org/bugs/show_bug.cgi?id=321819 

we would then have to implement org.eclipse.equinox.internal.p2.repository.Transport

Maybe that's a better option if we have a strong opinion on which HTTP client to use
(and someone with experience on how this HTTP client is used for best performance/stability).

Jan

From: tycho-dev-bounces@xxxxxxxxxxx [mailto:tycho-dev-bounces@xxxxxxxxxxx] On Behalf Of Jason van Zyl
Sent: Mittwoch, 17. August 2011 14:44
To: Tycho developers list
Subject: Re: [tycho-dev] ECF: HTTP connection reuse

Where did the patch ever go from someone at SAP that made the transport layer fully pluggable?

On Aug 17, 2011, at 3:19 AM, Sievers, Jan wrote:


FYI

https://bugs.eclipse.org/bugs/show_bug.cgi?id=297742#c19 

as soon as this patch gets accepted we should consume it and try enabling HTTP connection reuse in tycho.
I expect performance gains for the p2 latency issue

https://bugs.eclipse.org/bugs/show_bug.cgi?id=347403 

Regards
Jan
_______________________________________________
tycho-dev mailing list
tycho-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/tycho-dev

Thanks,

Jason

----------------------------------------------------------
Jason van Zyl
Founder,  Apache Maven
http://twitter.com/jvanzyl
---------------------------------------------------------

We know what we are, but know not what we may be.

  -- Shakespeare




Thanks,

Jason

----------------------------------------------------------
Jason van Zyl
Founder,  Apache Maven
http://twitter.com/jvanzyl
---------------------------------------------------------

Simplex sigillum veri. (Simplicity is the seal of truth.)