Mark, I just have to
smile... These are some of the exact reasons why some of us didn't want
to re-open this can of worms. What sounds like an "easy"
task needs to be discussed, vetted, and approved before we can start making
these type of decisions. All that I was doing was relaying some of
the conversation from this morning's Platform call and the ".api"
suffix had a thumbs down on the call. Mainly because the project
itself and the associated api is already known as an "api". So,
providing the "api" suffix seemed superfluous. For example,
will there every be a "jakarta.servlet.impl" module? Probably
not. Jakarta produces APIs, not Impls.
I think everyone
is in agreement that "java.servlet" is not correct as the automatic
module name. The simple update is to rename this to "jakarta.servlet"
-- just to correct the "java" prefix error.
Now, if you decide
to include the ".api" suffix, you are probably no more right
or no more wrong than anything else the other projects have chosen because
we don't have a complete answer for the module naming convention yet.
Which is making
me come to the conclusion that we should stick to our original premise
that we're not going to be concerned with "proper" modules names
in Jakarta EE 9. They don't apply to Java SE 8 -- which we just decided
is our first priority. When we decide to support Java SE 11, then
we can have the full-blown conversation about the naming convention. I'll
start this thread on the Platform and Spec Project Leads mailing list so
that we can (hopefully) close on it in short order.
for the input! --------------------------------------------------- Kevin Sutter STSM, MicroProfile and Jakarta EE architect @ IBM e-mail: sutter@xxxxxxxxxx Twitter: @kwsutter phone: tl-553-3620 (office), 507-253-3620 (office) LinkedIn: https://www.linkedin.com/in/kevinwsutter
Thomas <markt@xxxxxxxxxx> To:
Re: [servlet-dev] Release staged 5.0.0 to Maven Central Sent
On 21/07/2020 18:25, Kevin Sutter
wrote: > Mark, > What other naming conventions are you referring to? The discussion
on > the call is that the trailing ".api" on some of the other
proposed > module names was wrong and should be removed.
If a formal decision has been made on JPMS names since then I don't recall seeing it. Given the lists I am subscribed to I would have expected to see any proposed naming policy and/or discussion about said policy and/or announcement of such policy.
Absent a formal decision, my recommendation continues to be "Take
the OSGI symbolic name and replace any "-" with ".". For
servlet that gives "jakarta.servlet.api"