Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [platform-ui-dev] Proposed name changes

The generic workbench shouldn't have anything "SDK" or "IDE" in it.
I suggest "Default" instead.

Stefan Xenos/Ottawa/IBM@IBMCA 
Sent by: platform-ui-dev-admin@xxxxxxxxxxx
05/06/2004 08:17 PM
Please respond to


[platform-ui-dev] Proposed name changes

I've been hearing a lot of questions about the purpose of various 
workbench internal classes. To help resolve some of this confusion, I 
would like to propose the following name changes (to non-API classes). 

PartStack (remains unchanged) 
PartTabFolder -> ViewStack 
EditorWorkbook -> EditorStack 

PartSashContainer (remains unchanged) 
RootLayoutContainer -> ViewSashContainer 
EditorArea -> EditorSashContainer 

BasicStackPresentation -> SdkPartPresentation 
PartTabFolderPresentation -> SdkViewPresentation 
org.eclipse.ui.internal.presentations.EditorPresentation -> 

org.eclipse.ui.internal.PerspectivePresentation -> PerspectiveHelper 
org.eclipse.ui.internal.EditorPresentation -> EditorAreaHelper 

This makes the names more consistent: The *Stack classes manage a set of 
tabs, the *SashContainers manage areas of Stacks separated by sashes, and 
the Sdk*Presentation classes are specific to the Eclipse 3.0 "new look". 
Similarly, the View* classes are specific to views, the Editor* classes 
are specific to editors, and the Part* classes are common to both editors 
and views. 

PerspectivePresentation and org.eclipse.ui.internal.EditorPresentation 
should be renamed (to anything, really) since they are commonly mistaken 
as part of the new presentation API, and we should avoid creating classes 
called "presentation" outside of the presentation packages. 

Please indicate if you think these name changes are worthwhile or have any 
other suggestions. 

  - Stefan

Back to the top