[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[pdt-dev] Bug 445275 - Migrate from org.eclipse.dltk.internal.core.SourceRange to api version

Hi Dawid,

Sometime ago I created a patch for deprecated SourceRange class, but I didn't have time to check it with 3rd party plugins to be sure they are compatible. Today I checked:
https://github.com/pulse00/Composer-Eclipse-Plugin
https://github.com/pdt-eg/Core-Plugin
https://github.com/pulse00/Symfony-2-Eclipse-Plugin

Symfony plugins are using part of API fromÂAbstractCompletionStrategy so I reorganized patch to not break anything. What other plugins you are checking in such cases?

https://bugs.eclipse.org/bugs/show_bug.cgi?id=445275

Thanks,
MichaÅ