Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [pde-dev] product failing to load multiple versions of the sameplugin

Hi Vincent

Can you check if this fix has solved the issue -

We are planning to port this in 4.5.2 via bug 480020.

Eclipse Modeling/ PDE
IBM Rational
EGL D Block - Bangalore, India
Office Phone No : +91 - 80 - 41776506

Inactive hide details for Vincent Smith ---11/05/2015 05:29:13 AM---Mars p2 repositories ( Smith ---11/05/2015 05:29:13 AM---Mars p2 repositories ( and

From: Vincent Smith <vinceos@xxxxxxxxxxx>
To: "pde-dev@xxxxxxxxxxx" <pde-dev@xxxxxxxxxxx>
Date: 11/05/2015 05:29 AM
Subject: [pde-dev] product failing to load multiple versions of the same plugin
Sent by: pde-dev-bounces@xxxxxxxxxxx

Mars p2 repositories ( and have 2 versions of several bundles:




Bundles with 1.6.0.v201011041432 version are required by BIRT and GMF and 1.7.0.v201011041433 are required by the Eclipse Platform.

The problem is when a product is launched, only the latest version of the batik plugins is included, which results in plugin validation failures at launch. The only way to address it is to add the plugins manually in the run configuration for the product. This is an unacceptable solution when it comes to building and deploying the feature-based product automatically from p2 sites.

I found a bugzilla article that shows this is not a new issue ( The article implies the the problem is in the org.eclipe.pde.ui plugin and a patch was supposed to have been applied in 4.5 that fixed this issue. If it has been fixed, can someone provide me an update site for the pde that contains the patch? If not, do you know when it will be fixed and updated?

pde-dev mailing list
To change your delivery options, retrieve your password, or unsubscribe from this list, visit

Back to the top