Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[pde-dev] product failing to load multiple versions of the same plugin

Mars p2 repositories ( and have 2 versions of several bundles:




Bundles with 1.6.0.v201011041432 version are required by BIRT and GMF and 1.7.0.v201011041433 are required by the Eclipse Platform.

The problem is when a product is launched, only the latest version of the batik plugins is included, which results in plugin validation failures at launch.  The only way to address it is to add the plugins manually in the run configuration for the product. This is an unacceptable solution when it comes to building and deploying the feature-based product automatically from p2 sites.

I found a bugzilla article that shows this is not a new issue ( The article implies the the problem is in the org.eclipe.pde.ui plugin and a patch was supposed to have been applied in 4.5 that fixed this issue. If it has been fixed, can someone provide me an update site for the pde that contains the patch? If not, do you know when it will be fixed and updated? 

Back to the top