|Re: [mdt-papyrus.dev] Notes of the preccomitting meeting|
Thibault LANDRE wrote:
The idea was good, but we are not a GMF demonstrator :-). They have named their plugins like that because they are gmf centric. This is not our case. GMF is just a tool that we use to produce diagrams. The artefact used for the generation should not appear abruptly in the plugins. And for me the names of the plugins should gives clear indication of their purpose/contents. 'def' and 'codegen' are not meaningful for me. This is why they should be renamed. Also, we may have such def/codegen for properties, diagrams and others. How we will do ? Mix all the stuff in the same 'def' plugin ? I think it is a bad idea.Cédric,I have named the plugin like they were denominated in the GMF and UMLTools project (for the same functionnality). I have kept this naming to avoid confusion for developers familiar with GMF and UMLTools.
Back to the top