[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [m2e-users] Eclipse Mars + Takari team - fail to install

I just built mavenarchiver 0.17.0 locally, so with a today's timestamp, and successfully installed it on the Java EE distro. So, other than the 0.17.0 lower constraint in Java EE, there really is no specific version locking there.

On Sun, Aug 23, 2015 at 3:48 PM, Igor Fedorenko <igorfie@xxxxxxxxxxxx> wrote:

Yes. Takari feature requires specific versions of everything. But mavenarchiver configurator version must be locked elsewhere too, otherwise installation would have succeeded.

--
Regards,
Igor

On August 23, 2015 3:34:34 PM Fred Bricon <fbricon@xxxxxxxxx> wrote:

Igor m2e-wtp requires mavenarchiver 0.17.0+, but doesn't lock to any specific version.

The version embedded in Java EE (0.17.0.201502101659-signed-20150525172209) is the same asÂhttp://repo1.maven.org/maven2/.m2e/connectors/m2eclipse-mavenarchiver/0.17.0/N/0.17.0.201502101659/Âonly repackaged and signed by eclipse.org server.

To me, the version lock comes from takari-team, since mavenarchiver is embedded by your distro:Âhttp://repo1.maven.org/maven2/.m2e/connectors/takari-team/0.1.0/N/0.1.0.201508210400/features/

On Sun, Aug 23, 2015 at 2:43 PM, Dan Tran <dantran@xxxxxxxxx> wrote:
actually JEE comes with the 0.17, so perhaps upgrade takari-team to use 0.17 may work?

Thanks


-Dan

On Sun, Aug 23, 2015 at 11:39 AM, Dan Tran <dantran@xxxxxxxxx> wrote:
Ouch!!! It is a hard requirement from TakariÂsince we need JEE

JEE comes with maven-archive connector versionÂ0.16.0.201410091840 Âand Takari team comes with 0.17

Is there a way to remove 0.16 from JEE prior to takari-team installation?

Thanks

-Dan


On Sun, Aug 23, 2015 at 10:44 AM, Igor Fedorenko <igor@xxxxxxxxxxxxxx> wrote:
Looks like something in Eclipse for Java EE has hard dependency on specific version of mavenarchiver, which conflicts with mavenarchiver version required by Takari Team feature. Nothing we can do from our side to fix this. If you don't specifically need Java EE functionality, I suggest you use clean(er) Eclipse distribution, "for Java" or "SDK". Or just pick the same components that are included in Takari Team feature
Â
Â
--
Regards,
Igor
Â
Â
On Sun, Aug 23, 2015, at 12:00 AM, Dan Tran wrote:
HIÂ
Â
I have a put together a set of Maven poms to auto provision Eclipse and additional features such as takari-team required by my dev team
Â
The pom uses exec-maven-plugin to with following similar config
Â
       <execution>
        <id>install-m2extra-takari-team</id>
        <phase>process-sources</phase>
        <goals>
         <goal>exec</goal>
        </goals>
        <configuration>
         <executable>${eclipse.home}/${eclipse.cmd}</executable>
         <arguments>
          <argument>-clean</argument>
          <argument>-purgeHistory</argument>
          <argument>-application</argument>
          <argument>org.eclipse.equinox.p2.director</argument>
          <argument>-noSplash</argument>
          <argument>-repository</argument>
          <!-- this assumes takari actively maintains the latest -->
          <argument>https://otto.takari.io/content/sites/m2e.extras/takari-team/0.1.0/N/LATEST/</argument>
          <argument>-installIUs</argument>
          <argument>io.takari.m2e.team.feature.feature.group</argument>
         </arguments>
        </configuration>
       </execution>
Â
Â
This works for Eclipse Luna SR2 but not with Eclipse Mars
Â
here is the error from command line
Â
[INFO] --- exec-maven-plugin:1.4.0:exec (install-m2extra-takari-team) @ eclipse-jee ---
org.eclipse.m2e.logback.configuration: The org.eclipse.m2e.logback.configuration bundle was activated before the state l
ocation was initialized. Will retry after the state location is initialized.
Installing io.takari.m2e.team.feature.feature.group 0.1.0.201508220400.
Installation failed.
Cannot complete the install because of a conflicting dependency.
ÂSoftware being installed: Takari TEAM for Eclipse 0.1.0.201508220400 (io.takari.m2e.team.feature.feature.group 0.1.0.20
1508220400)
ÂSoftware currently installed: Eclipse IDE for Java EE Developers 4.5.0.20150621-1200 (epp.package.jee 4.5.0.20150621-12
00)
ÂOnly one of the following can be installed at once:
 m2e connector for the mavenarchiver and pom properties 0.17.0.201502101659-signed-20150525172209 (org.sonatype.m2e.mav
enarchiver 0.17.0.201502101659-signed-20150525172209)
 m2e connector for the mavenarchiver and pom properties 0.16.0.201410091840 (org.sonatype.m2e.mavenarchiver 0.16.0.2014
10091840)
Â
Also, attempt to install https://otto.takari.io/content/sites/m2e.extras/takari-team/0.1.0/N/LATEST directly using Eclipse UI also fail
Â
Â
is it something that Takaki can fix?
Â
Â
Thanks
Â
-Dan
Â
PS. I am using Java 8
_______________________________________________
m2e-users mailing list
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
Â

_______________________________________________
m2e-users mailing list
m2e-users@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/m2e-users



_______________________________________________
m2e-users mailing list
m2e-users@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/m2e-users



--
"Have you tried turning it off and on again" - The IT Crowd
And if that fails, thenÂhttp://goo.gl/tnBgH5
_______________________________________________
m2e-users mailing list
m2e-users@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https:/â/âdevâ.âeclipseâ.âorg/âmailman/âlistinfo/âm2e-users



--
"Have you tried turning it off and on again" - The IT Crowd
And if that fails, thenÂhttp://goo.gl/tnBgH5