[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [m2e-users] Eclipse Mars + Takari team - fail to install

I make my own distribution using a Tycho repository project but ultimately with the same mechanism youâre using. I can give a try and let you know how that goes.

> On Aug 23, 2015, at 12:00 AM, Dan Tran <dantran@xxxxxxxxx> wrote:
> 
> HI 
> 
> I have a put together a set of Maven poms to auto provision Eclipse and additional features such as takari-team required by my dev team
> 
> The pom uses exec-maven-plugin to with following similar config
> 
>               <execution>
>                 <id>install-m2extra-takari-team</id>
>                 <phase>process-sources</phase>
>                 <goals>
>                   <goal>exec</goal>
>                 </goals>
>                 <configuration>
>                   <executable>${eclipse.home}/${eclipse.cmd}</executable>
>                   <arguments>
>                     <argument>-clean</argument>
>                     <argument>-purgeHistory</argument>
>                     <argument>-application</argument>
>                     <argument>org.eclipse.equinox.p2.director</argument>
>                     <argument>-noSplash</argument>
>                     <argument>-repository</argument>
>                     <!-- this assumes takari actively maintains the latest -->
>                     <argument>https://otto.takari.io/content/sites/m2e.extras/takari-team/0.1.0/N/LATEST/</argument>
>                     <argument>-installIUs</argument>
>                     <argument>io.takari.m2e.team.feature.feature.group</argument>
>                   </arguments>
>                 </configuration>
>               </execution>
> 
> 
> This works for Eclipse Luna SR2 but not with Eclipse Mars
> 
> here is the error from command line
> 
> [INFO] --- exec-maven-plugin:1.4.0:exec (install-m2extra-takari-team) @ eclipse-jee ---
> org.eclipse.m2e.logback.configuration: The org.eclipse.m2e.logback.configuration bundle was activated before the state l
> ocation was initialized.  Will retry after the state location is initialized.
> Installing io.takari.m2e.team.feature.feature.group 0.1.0.201508220400.
> Installation failed.
> Cannot complete the install because of a conflicting dependency.
>  Software being installed: Takari TEAM for Eclipse 0.1.0.201508220400 (io.takari.m2e.team.feature.feature.group 0.1.0.20
> 1508220400)
>  Software currently installed: Eclipse IDE for Java EE Developers 4.5.0.20150621-1200 (epp.package.jee 4.5.0.20150621-12
> 00)
>  Only one of the following can be installed at once:
>   m2e connector for the mavenarchiver and pom properties 0.17.0.201502101659-signed-20150525172209 (org.sonatype.m2e.mav
> enarchiver 0.17.0.201502101659-signed-20150525172209)
>   m2e connector for the mavenarchiver and pom properties 0.16.0.201410091840 (org.sonatype.m2e.mavenarchiver 0.16.0.2014
> 10091840)
> 
> Also, attempt to install https://otto.takari.io/content/sites/m2e.extras/takari-team/0.1.0/N/LATEST directly using Eclipse UI also fail
> 
> 
> is it something that Takaki can fix?
> 
> 
> Thanks
> 
> -Dan
> 
> PS. I am using Java 8
> _______________________________________________
> m2e-users mailing list
> m2e-users@xxxxxxxxxxx
> To change your delivery options, retrieve your password, or unsubscribe from this list, visit
> https://dev.eclipse.org/mailman/listinfo/m2e-users

Thanks,

Jason

----------------------------------------------------------
Jason van Zyl
Founder, Takari and Apache Maven
http://twitter.com/jvanzyl
http://twitter.com/takari_io
---------------------------------------------------------

A party which is not afraid of letting culture,
business, and welfare go to ruin completely can
be omnipotent for a while.

  -- Jakob Burckhardt