Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [jta-dev] Intending to create a 2.0.1-RC1

I'm not really sure why grgrgrzybak added the 1.2 and 1.3 exports here:

It seems very wrong, but I'm not sure what the line of thinking was.

On Thu, Feb 3, 2022 at 5:56 PM Tom Jenkinson <tom.jenkinson@xxxxxxxxxx> wrote:
jakarta.transaction-api doesn't seem to have changed from Jakarta EE 9. That said, I have a PR that I hope can work:

On Thu, 3 Feb 2022 at 16:41, Tom Jenkinson <tom.jenkinson@xxxxxxxxxx> wrote:
I have had a look inside a recent built version, I am wondering if it is this `Bundle-SymbolicName` which is jakarta.transaction-api that might be the difference?:

Manifest-Version: 1.0
Archiver-Version: Plexus Archiver
Created-By: Apache Maven Bundle Plugin
Built-By: jenkins
Build-Jdk: 11.0.2
Automatic-Module-Name: jakarta.transaction
Bnd-LastModified: 1643898344762
Build-Jdk-Spec: 11
Bundle-Description: Jakarta(TM) Transactions 2.0 API Design Specificatio
Bundle-License:, https://www.gnu.or
Bundle-ManifestVersion: 2
Bundle-Name: jakarta.transaction API
Bundle-SymbolicName: jakarta.transaction-api
Bundle-Vendor: EE4J Community
Bundle-Version: 2.0.1
Export-Package: javax.transaction;uses:="javax.interceptor,javax.transac
Extension-Name: jakarta.transaction
Implementation-Vendor: EE4J Community
Implementation-Vendor-Id: org.glassfish
Implementation-Version: 2.0.1
Import-Package: jakarta.enterprise.context;version="[3.0,4)",jakarta.ent
Specification-Vendor: Oracle Corporation
Specification-Version: 2.0
Tool: Bnd-

On Thu, 3 Feb 2022 at 16:38, Tom Jenkinson <tom.jenkinson@xxxxxxxxxx> wrote:
Thank you, Arjan. I wonder if the OSGi information in the transaction jar isn't identifying itself as jakarta.transaction. I will take a look at that.

On Thu, 3 Feb 2022 at 16:33, arjan tijms <arjan.tijms@xxxxxxxxx> wrote:
If you pretty print the OSGi/Felix output it's a bit easier to see:

Unable to resolve
    org.glassfish.main.resources.mail-connector [207]
    missing requirement
        &(package = jakarta.resource) (version >= 2.0.0) (!(version >= 3.0.0))
        caused by:
            Unable to resolve
                jakarta.resource-api [148]
                missing requirement
                    &(package = jakarta.transaction) (version >= 2.0.0) (!(version >= 3.0.0)))]

This by itself looks somewhat strange, since 2.0.1 is obviously in that range. Might rather be that it's not found at all.

Kind regards,
Arjan Tijms

jta-dev mailing list
To unsubscribe from this list, visit
jta-dev mailing list
To unsubscribe from this list, visit

Back to the top