[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [jgit-dev] [egit-dev] Raising minimum supported Eclipse platform version from 4.5 to 4.6

I am fine with going to 4.6 (Neon.0). Our 4.5 (Mars) compatibility was more lip
service anyway since the CI builds build against 4.6.

> On 27 Jan 2019, at 21:03 , Mickael Istria <mistria@xxxxxxxxxx> wrote:
> 
> +1 ! Even for moving to 4.11 as mininal target ;)

I am not fine with going to 4.11. EGit has a long history of supporting older
platforms, and there is in fact not much code that would need or benefit from
features added since 4.6.

Besides, I am always happy when I can install the latest and greatest EGit
in some commercial products based on stone-age platforms. RSA is
such a case; the latest RSA 9.7 is based on Oxygen. I recently had to use
RSA 9.1 (based on Juno!), which meant I couldn't go beyond EGit 4.5. I
realized only then how much better EGit 5.3 is!

Cheers,

  Thomas