[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[jgit-dev] Raising minimum supported Eclipse platform version from 4.5 to 4.6

We intend to raise the minimum supported Eclipse platform version from 4.5 to 4.6 in JGit/EGit 5.3.
4.5 was the last platform version running on Java 7 which reached end of standard maintenance in 2015.
This move will help to limit the number of target platform versions we are maintaining and allow us to
  • generify all the getAdapter() methods in EGit
  • and to add the smartimport bundle, which is supported starting from Eclipse 4.6, to the standard EGit feature.
See
https://wiki.eclipse.org/Eclipse/Installation/Java8Required
https://git.eclipse.org/r/#/c/135799/
https://git.eclipse.org/r/#/c/135801/

-Matthias