[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [jgit-dev] MANIFEST not working


----- Ursprungligt meddelande -----

> 2.0.12 is equivalent to [2.0.12,) i.e. this would accept 2.0.12 or
> higher
> so if you want to pin it to 2.0.12 you need to set
> version="[2.0.12,2.0.12)"

Ah, thanks.

That would include 2.0.12 up to but NOT including 2.0.12,
and therefore Eclipse doesn't accept it. I tried [2.0.12,2.0.12],
but that had the same effect as just 2.0.12. I also tried
[2.0.12,2.0.13) with no change.

> 
> though I am not sure if this answers your question

No, it doesn't.

-- robin
> 
> + org.kohsuke.args4j.spi;version="[2.0.12,2.0.12]"
> diff --git a/org.eclipse.jgit.pgm/META-INF/MANIFEST.MF
> b/org.eclipse.jgit.pgm/META-INF/MANIFEST.MF
> index df026e0..f43ca57 100644
> --- a/org.eclipse.jgit.pgm/META-INF/MANIFEST.MF
> +++ b/org.eclipse.jgit.pgm/META-INF/MANIFEST.MF
> @@ -29,8 +29,8 @@ Import-Package:
> org.eclipse.jgit.api;version="[2.2.0,2.3.0)",
> org.eclipse.jgit.treewalk.filter;version="[2.2.0,2.3.0)",
> org.eclipse.jgit.util;version="[2.2.0,2.3.0)",
> org.eclipse.jgit.util.io ;version="[2.2.0,2.3.0)",
> - org.kohsuke.args4j;version="[2.0.12,2.1.0)",
> - org.kohsuke.args4j.spi;version="[2.0.12,2.1.0)"
> + org.kohsuke.args4j;version="2.0.12",
> + org.kohsuke.args4j.spi;version="2.0.12"
> Bundle-ActivationPolicy: lazy
> Export-Package: org.eclipse.jgit.pgm;version="2.2.0";
> uses:="org.eclipse.jgit.lib,
> diff --git a/org.eclipse.jgit.pgm/pom.xml
> b/org.eclipse.jgit.pgm/pom.xml
> index a889a54..8cc732c 100644
> --- a/org.eclipse.jgit.pgm/pom.xml
> +++ b/org.eclipse.jgit.pgm/pom.xml
> @@ -69,7 +69,7 @@
> <dependency>
> <groupId>args4j</groupId>
> <artifactId>args4j</artifactId>
> - <version>[2.0.12,2.1.0)</version>
> + <version>2.0.12</version>
> </dependency>
> 
> <dependency>
> _______________________________________________
> jgit-dev mailing list
> jgit-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/jgit-dev
> 
> --
> Matthias
>