[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [jgit-dev] [egit-dev] about jetty

2012/6/4 Markus Duft <markus.duft@xxxxxxxxxx>
Hey!

Jetty 7.6 is required now. How am i supposed to get this, and what for is it required? Do i have to install 7.6 only in environments where i develop jgit/egit (to run tests, etc.) or is it a runtime dependency too?

For the "normal" RCP Devloper package of Eclipse 3.7.1 i'm unable to install jetty 7.6 as 7.5 is a dependency of the eclipse package... :*( i cannot compile without reverting your jetty related commits locally now.

Any hints? probably i'm just doing something wrong :)

I was struggling with this mess since some weeks until I found
this solution (maybe there is still a better one ?).

I updated the corresponding section in the contributor guide
http://wiki.eclipse.org/EGit/Contributor_Guide#JGit_HTTP_Tests
but forgot to post this on the list.

I tried keeping Jetty 7.5 as an option to run the JGit tests butÂJetty movedÂ
a couple of classes to another package between these 2 releases :(
I tried to workaround using reflection but this became so messy that
I decided we better update the requirement to 7.6 instead of maintaining
a messy workaround. If somebody has a better proposal I am happy to
try it.

The only way I found to make this work in Eclipse 4.2 is to use a target
platform since Eclipse 4.2 comes with Jetty 8.1 and I wasn't able to install
Jetty 7.x on top of this since this ended in an installation conflict. I also
failed to uninstall the Jetty 8.1. WeÂshould try to sort this out until 4.2 SR1
in September. Target platforms are defined for 3.7 and 4.2 inÂ
org.eclipse.egit.target on stable-2.0.

--
MatthiasÂ