Tiny, tiny, correction; it's just "Faces", not "Server Faces" ;)
Regarding the cloud profile, with "Dependency Injection", do you actually refer to the JSR 330 fork? As that's actually a dependency of CDI, and not something the platform suggests to use on its own (correct me if I'm wrong), maybe the picture can be simplified by omitting it?
Maybe half offtopic here, but maybe not. What about folding JSON Processing and JSON Binding into just JSON? Then rename Jakarta Restfull WebService to Jakarta REST and Bean Validation to Validation. If (big if) the current Dependency Injection can be folded into CDI, then CDI Lite could use the simple name Dependency Injection.
The Cloud Profile could then be:
IMHO, just by those names alone, makes it look a lot smaller, simpler and easier to comprehend what it does.