Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [jakartaee-platform-dev] [] JakartaSecurity Spec Namespace Mismatch



Thanks, it already exists

However, the API package is currently "", I mentioned on different occasions, that simply renaming "javax" to "jakarta" is not always the proper solution, at least in this case it creates lots of confusion unless the Java packages were also renamed to match the project/spec name. also exists for Authorization.

There it is also equally complex, the Java package is just named "", the groupId "jakarta.authorization", so IMO both would have to change for a proper match.




Sent from Mail for Windows 10


From: Kevin Sutter
Sent: Monday, February 17, 2020 20:15
To: Jakarta specification committee
Cc: jakartaee-platform developer discussions
Subject: Re: [jakartaee-platform-dev] [] JakartaSecurity Spec Namespace Mismatch


Here's a pointer to our Jakarta EE naming conventions:

This would indicate that Authentication should follow suit and change the groupId and artifactId to be consistent.  Why don't you go ahead and write an Issue for this?  Thanks!

Kevin Sutter
STSM, MicroProfile and Jakarta EE architect @ IBM
e-mail:  sutter@xxxxxxxxxx     Twitter:  @kwsutter
phone: tl-553-3620 (office), 507-253-3620 (office)    

From:        Werner Keil <werner.keil@xxxxxxx>
To:        jakartaee-platform developer discussions <jakartaee-platform-dev@xxxxxxxxxxx>
Cc:        Jakarta specification committee <>
Date:        02/17/2020 12:42
Subject:        [EXTERNAL] [] Jakarta Security Spec Namespace Mismatch
Sent by:




I recently noticed, that renaming some specs like JASPIC to another Jakarta name had a side-effect of a mismatch and inconsistency of the Maven GroupIds.


While Jakarta Autorization ( ended up with:




Its sibling Jakarta Authorization ( sticks with a GroupId root already known by Jakarta Security:




Was there a reason to abandon the "" prefix for one, but keep it for the other?


Also IMO "" is wrong on so many levels, to start with it confuses people with Jakarta Messaging because the word "message" and the acronym "auth" tells nothing whether it is "authorization" or "authentication".


Since they were both recently changed from the "javax" namespace, I doubt either of them are "given by God" now, so could we at least harmonize them, either with the "" prefix or without?




 _______________________________________________ mailing list
To change your delivery options, retrieve your password, or unsubscribe from this list, visit



Back to the top