Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [jakartaee-platform-dev] Transitioning Jakarta EE to the jakarta namespace

I'd definitely prefer to not have enterprise in the package name. However, I'm still not convinced that any spec from MP or any 3rd party component need to change package names to be included in Jakarta EE. Though that is perhaps a discussion for another day/thread :)

Sent from my iPhone

On 25 Sep 2019, at 16:48, BJ Hargrave <hargrave@xxxxxxxxxx> wrote:

If we consider that "jakarta" == "org.eclipse.enterprise", that is "jakarta" is the enterprise Java package root, then it does not matter and "jakarta" has the value of being shorter and more distinctive.
It could be that even MicroProfile may consider defining new specifications under the "jakarta" package root to allow for the case where the MicroProfile specification may one day be included in a Jakarta EE release.
So I would not view the "jakarta" package root as implying the Jakarta EE brand or Jakarta EE releases but instead as the successor package root for "javax" as the place for enterprise Java API.

BJ Hargrave
Senior Technical Staff Member, IBM // office: +1 386 848 1781
OSGi Fellow and CTO of the OSGi Alliance // mobile: +1 386 848 3788
----- Original message -----
From: Thomas Andraschko <andraschko.thomas@xxxxxxxxx>
Sent by: jakartaee-platform-dev-bounces@xxxxxxxxxxx
To: jakartaee-platform developer discussions <jakartaee-platform-dev@xxxxxxxxxxx>
Subject: [EXTERNAL] Re: [jakartaee-platform-dev] Transitioning Jakarta EE to the jakarta namespace
Date: Wed, Sep 25, 2019 09:54
IMO org.eclipse.enterprise.* instead jakarta.* would make JakartaEE somthing like minor and 
unimportant. Just like "some random lib hosted on eclipse".
Just replacing all javax with jakarta for the packages is the perfect choice IMO.
javax.faces -> jakarta.faces
Just not sure about CDI as the namespace is javax.enterprise.inject.
I think moving JSR330 annotations to CDI and call it jakarta.inject would be a very very nice decision.
Phillip Kruger <phillip.kruger@xxxxxxxxx> schrieb am Mi., 25. Sep. 2019, 13:50:
Hi All.
I have some thoughts on the new package name (Jakarta).
Just an idea. Let me know what you think.

jakartaee-platform-dev mailing list
To change your delivery options, retrieve your password, or unsubscribe from this list, visit

Back to the top