[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [ide-dev] Fixing the Target platform editor



On 22 November 2016 at 14:44, Gunnar Wagenknecht <gunnar@xxxxxxxxxxxxxxx> wrote:

On 22 Nov 2016, at 14:43, Mickael Istria <mistria@xxxxxxxxxx> wrote:

In an ideal world, such improvements would have directly happened in PDE and the .target format and editor...

Keep in mind that it's not just PDE but PDE plus Tycho plus potentially p2. Thus, three different projects would need to be touched (depending on the feature/limitation you want to remove). Three different legacy code based. Three different project teams to communicate with.Â



That's a good point, it would be great to address PDE <-> Tycho integration because it can be a big pain point at the moment, as Mickael also knows well.

Namely, that POM-first dependencies don't work in PDE/.target at all, meaning that builds that use POM-first dependencies have to go through all sorts of hoops to provide a .target to be used in the IDE environment. (Usually involving some manual work to create such .target, bundle POM libs into OSGI bundle, etc...)

--