[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [eclipselink-users] EclipseLink readme doesn't tell about knownbugs and application server supported

Thanks for the info. 

So if the only errors reported by unit tests running on WebSphere are
about too early query construction it seems that test coverage for the
WebSphere specific integration code is missing. I have updated the
existing WebSphere showstopper bug:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=225621

And created a documentation bug against release notes:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=246638
 


-----Original Message-----
From: eclipselink-users-bounces@xxxxxxxxxxx
[mailto:eclipselink-users-bounces@xxxxxxxxxxx] On Behalf Of James
Sutherland
Sent: Monday, September 08, 2008 10:20 AM
To: eclipselink-users@xxxxxxxxxxx
Subject: Re: [eclipselink-users] EclipseLink readme doesn't tell about
knownbugs and application server supported


Feel free to log a documentation bug to have any specific bugs
documented in
the release notes.  Or create a know bugs page on the wiki.

As far a WebSphere goes, it is currently tested nightly with
EclipseLink. 
If you are encountering any issues with WebSphere please log the issue
in
Bugzilla.  I agree the wiki should include which applications servers
and
environments are being tested and the results.  Currently only the
nightly
run, run within Eclipse is sent to the dev mailing list, which only runs
the
LRGs on MySQL.  This is because we cannot, or there are legal/technical
issues with putting WebSphere or other third party products on the
Eclipse
servers.  Within Oracle we do run the complete set of tests and do run
nightly tests on other servers and databases.

I'm not sure if other committers are testing EclipseLink on other
application servers but the environments EclipseLink is currently being
tested within Oracle include:
- Oracle WebLogic 10.1
- Oracle WebLogic 10.3
- Oracle OC4J 10.1.3
- IBM WebSphere 6.1
- JBoss 4.2
- Spring 2.5
- Oracle DB 11
- Oracle DB 10
- MySQL 5
- DB2 9
- Sybase 15
- SQL Server 2005
- Sun JDK 1.5
- Sun JDK 1.6


I believe that our Sun committers also test EclipseLink on Glassfish.


Results for WebSphere, below.  There are a few tests failing currently,
but
they are only related to the tests incorrectly creating queries before
the
JTA transaction begins, (other servers seem to be ok with this, but the
tests need to be updated).


>>
JPA tests on websphere(version 6.1)
JAVA_HOME=/scratch/aime/eclipselink/org.eclipse.persistence/was/java
ANT_HOME=/ade_autofs/ade_linux/TOPLINK_MAIN_GENERIC.rdd/LATEST/ant
Database server: oracle(version 10.2)
Directory: trunk/jpa/eclipselink.jpa.test/
Ant target: server-test-lrg
Tests Failures Errors Success rate Time 
140 0 19 86.43% 31.217 
JUnit Test Report ANT log 



Sebastien Tardif-2 wrote:
> 
> Please provide more information in the readme about what are the bugs
> known and not yet fixed in the release and on which application
servers
> EclipseLink has been tested.
> 
> I have been using WebSphere with TopLink, which is certified so I
> wrongly assumed that EclipseLink was also tested/certified with
> WebSphere.
> 


-----
---
http://wiki.eclipse.org/User:James.sutherland.oracle.com James
Sutherland 
http://www.eclipse.org/eclipselink/
 EclipseLink ,  http://www.oracle.com/technology/products/ias/toplink/
TopLink 
Wiki:  http://wiki.eclipse.org/EclipseLink EclipseLink , 
http://wiki.oracle.com/page/TopLink TopLink 
Forums:  http://forums.oracle.com/forums/forum.jspa?forumID=48 TopLink ,

http://www.nabble.com/EclipseLink-f26430.html EclipseLink 
Book:  http://en.wikibooks.org/wiki/Java_Persistence Java Persistence 
-- 
View this message in context:
http://www.nabble.com/Validating-schema-tp19316501p19373044.html
Sent from the EclipseLink - Users mailing list archive at Nabble.com.

_______________________________________________
eclipselink-users mailing list
eclipselink-users@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/eclipselink-users